Skip to Content
author's profile photo
Former Member

Unable to syndicate

HI Frnds,

I have a problem in syndicating records to a Flat file. I designed data model and enabled key mapping to YES. Created 2 Client systems and imported data in to data manager from 2 differnet clients (8 records from Client1 and 3 records from Client2).

In syndicator Manager i chosed destination properties, client system as Client2, Format as flat. Supress record with out Key as checked. In preview i can see 3 records from Client2 When i tried to execute Syndication, it syndicating all 11 records and when i try to check key mappings for client1 records i see 2 Key mappings Client1 and Client2.

How can just syndicate Client2 records i.e., 3 records whcih i imported through Client2?

Thanks in advance,

Raj

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Posted on Jun 04, 2007 at 02:47 PM

    Hi Raj,

    open your syndication map in syndicator. Switch to tab "Map Properties". Have a look at property "Output Remote Systems". Depending on the configuration you maintained there, syndicator collects all records that belong to the defined remote system. So if you want to distribute only those records belonging to Client2, make sure that you've defined Client2 as an output system!

    BR

    Michael

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi ,

      Will the syndication occur succesfully if a new in/outbound system is created in the console. Key mapping is enabled for the main table, and the syndication map is created for this new system with type flat.Data for this system is uploaded in the IM using an excel import.

      While syndicating the syndicate option is not enabled in this case & syndication does not occur.Are there any further settings to be maintianed ?

      Regards,

      Anita

  • Posted on Jun 04, 2007 at 12:08 PM

    Hi Rajeev,

    It seems that you have selected key generation property as "Range" for you client systems. Please check this using Console >your repository->Admin--> Remote/Client Systems and after navigating to client systems, select your client system and check Key Generation Property. If yes then please change it from "Range" to "None". Then provide remote key values and proceed in the same way in syndicator and your problem will be solved also only one key will be applied on the records.

    Hope your problem will be solved. Revert back to me for further queries.

    Thanks,

    <b>Shiv.</b>

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Rajeev,

      The Key Generation property allows to specify how keys would be generated for new records.

      <b>** </b>If you specify key generation as "None", then newly generated records will not contain any remote key value. you have to supply remote key values either manually using data manager or by mapping remote key field with any source field using import manager.

      <b>** </b> If you specify key generation as "Range", then newly generated records will contain the key with in the range specified in the key generation property ( i.e. within to and from values).

      <b>** </b> If you specify key generation as "qualified Range", then you have to specify the a lookup table and range of remote keys for each values of the lookup table.

      Hope this will make your concepts much clear. Please revert back for further queries.

      Thanks,

      <b>Shiv.</b>