Skip to Content
0

Database Connection Error: 'Cannot obtain error message from the server.'

Jul 06, 2017 at 05:40 PM

89

avatar image
Former Member

Trying to run a report with data from Salesforce:

1. Successfully connected to Salesforce database.

2. Refresh report, receive this error: capture1.png

3. After clicking 'OK', receive this error: capture.png

Here's what I've tried to troubleshoot:

- Ran the same report on another computer and it worked. I used the same Salesforce login to access the same database.

- On my own computer, I successfully created a new report with some fields from the same tables in the same database as the original report.

I'm using Crystal Reports 2016.

capture1.png (10.4 kB)
capture.png (13.0 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Vitaly Izmaylov
Jul 10, 2017 at 02:29 PM
0

There could be some defect with the Simba driver. What I would suggest is try to rebuilt the report. You do not need to recreate the report design, just bring the same objects and do the same table linking. The "Show SQL Query" should be matching the original report query. Will it work?

Show 9 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thanks for the suggestion. I installed CR2011 and the report finally worked.

0

With CR 2011 you are back to the original driver. Soon it would not be supported and you will be back to the same problem with CR 2016 or CR 2013.

0
Former Member

I see this is only a short term solution. When I tried to create a new report using CR 2011 this error popped up:

I was able to connect to the Salesforce database when running the old report. In Report Expert, after logging into the database it shows this:

capture.png (12.5 kB)
capture.png (671 B)
0
0
Former Member

The crconfig.xml is not located in the same place on my computer as instructed.

There's only a file called lib located in C:Program Files\Business Objects\common\3.5\java.

So I searched up crconfig.xml and was able to locate <JVMMaxHeap>64000000</JVMMaxHeap>. However, when I tried to save, this error popped up:

Current version: 14.0.4.738 RTM. Do I need to install a newer service pack?

capture.png (36.7 kB)
0

C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\java

0
Former Member

That's where I tried to modify the numbers and couldn't save. Got the error message in my previous post.

0

It is Windows security.

Save the modified file to desktop.

Then copy the file from the desktop and save to the destination.

0
Former Member

Thank you!

0
Vitaly Izmaylov
Jul 06, 2017 at 09:01 PM
0

Does report have records selection formula?

Show 6 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Yes and after removing it, the same errors occur.

Installed service pack 4 patch 1 and error still occurs.

The original report was created on CR 2011, could it be incompatible for my 2016 version?

0

Can you copy the SOQL query from the original report and from the brand new report you created.

Go to Database > Show SQL Query

Do you see any difference in Syntax?

0
Former Member

I don't see any difference in Syntax. Please see below.


SQL query from the original report:

SELECT "Account"."A_R_No__c", "Account"."Name", "Projects__c"."Free_Hours__c", "Projects__c"."Contracted_Hours_not_inc_free_hours__c", "Projects__c"."Name", "Account"."BillingStreet", "Account"."BillingCity", "Account"."BillingState", "Account"."BillingPostalCode", "Account"."BillingCountry", "Billable_Hours__c"."Number_of_Hours__c", "Billable_Hours__c"."Date__c", "Projects__c"."Id", "Projects__c"."Hours_Reamininhg__c", "Projects__c"."Total_Hours_Delivered__c", "Billable_Hours__c"."Status__c" FROM {oj "STEMSOFT"."STEMSOFT"."Billable_Hours__c" "Billable_Hours__c" LEFT OUTER JOIN ("STEMSOFT"."STEMSOFT"."Projects__c" "Projects__c" INNER JOIN "STEMSOFT"."STEMSOFT"."Account" "Account" ON "Projects__c"."Account__c"="Account"."Id") ON "Billable_Hours__c"."ProjecProjectt__c"="Projects__c"."Id"} WHERE "Billable_Hours__c"."Status__c"='SENT TO FINANCE' ORDER BY "Account"."A_R_No__c", "Projects__c"."Name", "Billable_Hours__c"."Date__c"

SQL query from the new report:

SELECT "Account"."A_R_No__c", "Account"."Name", "Projects__c"."Name", "Projects__c"."Total_Hours_Contracted__c" FROM "STEMSOFT"."STEMSOFT"."Projects__c" "Projects__c" INNER JOIN "STEMSOFT"."STEMSOFT"."Account" "Account" ON "Projects__c"."Account__c"="Account"."Id"

0
Former Member

I tried to run some other reports on two computers. Mine never runs the report successfully and the other computer running on CR2013 was able to run those reorts with the same Salesforce login info. It's the software itself.

0

I agree, there is a difference between CR 2011 (java based internal SAP developed SFDC driver) and CR 2016 (outsourced third party Simba driver).

But there are no differences between CR 2013 and CR 2016 regarding SFDC connectivity. May be just few fixes.

Try the following steps:

Open the report on working machine in CR 2013 , click Database > Verify Database and save the report.

Then open the report in CR 2016 on your machine and refresh it. Does it work?

0
Former Member

It didn't work. And turns out the working machine runs on CR 2011. So it's probably the driver. Does that mean all CR 2016 users can't run reports that were created using CR 2011? There must be a fix for this.

0
Vitaly Izmaylov
Jul 07, 2017 at 10:48 PM
0

To be honest there were many issues with SFDC reports after the new driver introduced in CR 2013, but most of them resolved before CR 2016 release. It should work.

What if you do Verify Database in CR 2016?

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

The same error shows up.

0