Skip to Content
avatar image
Former Member

Xapp Analytics error

Dear all

Running: NW2004s SP11

I am trying to implement the Xapps for analytics (Account Analytics) and have done as follows:

1) Unzip the XAPPCPACCAN00_0-10004330 archive with winrar

2) Then unzip the sap.com_iscpxappscpaccan2vc.sda

3) Now i have the XAP_CP_ACCAN.gml which I have imported to the Visual Composer with succes

4) I hav'nt done any modification to the imported VC model but just deployed the model to the portal - with succes

5) After deploying the browser now starts up with the model but here I get an error saying:

<b>"Nested Exception. Failure to execute native fucntion. Nested Exception. INVALID_INPUT"</b>

Now what ?

In the defaultTrace.trc file I have lots of errors saying:

#1.5#000D60518A560060000004AF000004E5000431AEC54637D5#1180526610626#com.sap.portal.visualComposer_NWBIKit_logger#sap.com/irj#com.sap.portal.visualComposer_NWBIKit_logger#DKTMPLB#9433##dkas4ch30.global_CND_153996050#DKTMPLB#c606cf400ea511dcc447000d60518a56#SAPEngine_Application_Thread[impl:3]_41##0#0#Info##Plain###value:#

#1.5#000D60518A560060000004B0000004E5000431AEC5463821#1180526610626#com.sap.portal.visualComposer_NWBIKit_logger#sap.com/irj#com.sap.portal.visualComposer_NWBIKit_logger#DKTMPLB#9433##dkas4ch30.global_CND_153996050#DKTMPLB#c606cf400ea511dcc447000d60518a56#SAPEngine_Application_Thread[impl:3]_41##0#0#Info##Plain###inputType:INPUT_FIELD#

#1.5#000D60518A560060000004B1000004E5000431AEC546386B#1180526610626#com.sap.portal.visualComposer_NWBIKit_logger#sap.com/irj#com.sap.portal.visualComposer_NWBIKit_logger#DKTMPLB#9433##dkas4ch30.global_CND_153996050#DKTMPLB#c606cf400ea511dcc447000d60518a56#SAPEngine_Application_Thread[impl:3]_41##0#0#Info##Plain###appName:0CP_BRND#

#1.5#000D60518A560060000004B2000004E5000431AEC54638B6#1180526610626#com.sap.portal.visualComposer_NWBIKit_logger#sap.com/irj#com.sap.portal.visualComposer_NWBIKit_logger#DKTMPLB#9433##dkas4ch30.global_CND_153996050#DKTMPLB#c606cf400ea511dcc447000d60518a56#SAPEngine_Application_Thread[impl:3]_41##0#0#Info##Plain###mapped:0#

#1.5#000D60518A560060000004B3000004E5000431AEC54638FF#1180526610626#com.sap.portal.visualComposer_NWBIKit_logger#sap.com/irj#com.sap.portal.visualComposer_NWBIKit_logger#DKTMPLB#9433##dkas4ch30.global_CND_153996050#DKTMPLB#c606cf400ea511dcc447000d60518a56#SAPEngine_Application_Thread[impl:3]_41##0#0#Info##Plain###value:#

......and so on

Please help me out

Lars

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    May 30, 2007 at 12:58 PM

    Hi Lars,

    Just by importig .gml file from business package, it will not work.

    You need to define the required back systems in portal. If they are already define in the backend, you have to either define system aliases for those systems, whichc should be same as in .gml file.

    How do we know what system aliases used in the .gml file?

    Go to Menu> Tools> Alias Manager. It shows a list of system aliases defined in the model. You can replace them with your system aliases or you can create same system aliases in the Portal systems.

    Thanks

    Venkata Ramakrishna

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Lars,

      Which queries need to be activated depends on "Queries used in the Model".

      You can find list of queries used inthe Model by clicking 'Browse' icon in the Panel Tool Bar. You need to activat ethem in the Backend BW system.

      I guess it is not posisble to activate queries without activating the InfoCube and dependent objects. BW guys can able to tell you which are need to be activated to work with these queries.

      Thanks

      Venkata Ramakrishna

  • avatar image
    Former Member
    Jun 12, 2007 at 02:27 AM

    Dear Marcel

    Thank you for your reply.

    And I hava one more question.

    When I will set the system alias,what should I select the system template?

    Now I'm trying to execute the xApp Analytics 1.1 SRM template.

    Regards

    Ogiwara

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Ogiwara,

      I have written a blog in the past about creating systems in the portal for using it in VC.

      Have a look into this <a href="/people/marcel.salein/blog/2007/03/14/how-to-create-a-portal-system-for-using-it-in-visual-composer">blog</a>.

      You have to use the same Systemalias as you have defined in the system configuration.

      Best Regards,

      Marcel

  • avatar image
    Former Member
    Jun 05, 2007 at 07:55 AM

    Hello.

    Now I'm trying to execute the Analytics,but same sympotom is occured.

    so I can't execute the Analytics.

    please help me.

    Regards

    OGiwara

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      please check if the connection to the backend system works fine and also check the aliases of the system. Then check the queries (execute them by right clicking in VC and choose test/define data service).

      Best Regards,

      Marcel

  • avatar image
    Former Member
    Jun 07, 2007 at 01:26 AM

    Hello

    Thanks for your reply.

    Now in my situation , I can compile xApp Analytics template on VC and deploy.

    But when I use the template on Portal, the error message is occured as follows.

    "Failed to connect to backend system.Check your system definition and your

    privileges"

    I checked "xApp Analytics 1.1 installation Guide", I didn't understand hot to ajdust the System Alias about Analytics Business Package on Portal.(page.9)

    Please teach me about it......

    Regards

    Ogiwara

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Shingo,

      you have to go at runtime in VC Menu --> Tools --> Alias Manager there you have to replace the Systemalias with your Systemalias. Before you do this you have to check in the portal under systemconfiguration that your connection to the backend is configured correctly (there you have to configure the systemalias. Also have a look here <a href="/people/marcel.salein/blog/2007/03/14/how-to-create-a-portal-system-for-using-it-in-visual-composer up a system for BI queries</a>.)

      Best Regards,

      Marcel

  • Jun 12, 2007 at 09:14 AM

    Hi Lars,

    You can open the model you imported from the PCD and check in the storyboard the values for the input in the BIQuery or Datasource are correct (by testing dataservice)

    Best Regards,

    Luis

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear all

      I think I have found out what we are missing!

      The Xapps uses Infoproviders 0CP_SLSM1 and 0CP_MP04 - but we don't have these in our system ? (search through RSA1)

      I think we are furfulling the system requirements : BI_CONT 7.03 SP5 - the documentation says 7.03 SP3

      Please help use

      Lars