Skip to Content
0

AS2 Missing Header

Jul 10, 2017 at 01:36 PM

87

avatar image

Hi,

we have made today following AS2 changes:

1. Port change from xxxx to default port 80
2. AS-2 URL has been changed accordingly
3. Our AS2-ID has been changed.
4. Additionally we changed our encryption and signing algorithms (switched to higher versions)
5. New market partner certificate has been installed.

Our market partner can send the messages to us, but once we try to send some messages, we get the following error:

[Jul 4, 2017 8:48:41 AM] mendelson_opensource_AS2-xxxxxxxxxxxxx-yyyyyyyyyyyyyyy_zzzzzzzzzzzzz: Message sent successfully (HTTP 200); 5.39 KB transfered in 125ms [43.12 KB/s].
[Jul 4, 2017 8:48:41 AM] mendelson_opensource_AS2-xxxxxxxxxxxxx-yyyyyyyyyyyyyyy_zzzzzzzzzzzzz: The received sync MDN seems not to be in right format. Missing header value "as2-to".

Our market partner has told us, we should change the "as2-to" value in the MDN to "AS2-To". But we are not sure, how and where exactly it can be done. As well they told us, they do not get any messages from us. Has anybody any idea, how we can solve it? Our AS-2 ID has been entered correctly by our market partner, as they can send the messages to us.

Thanks!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Manoj K Jul 10, 2017 at 04:38 PM
0

Dhiraj,

AFAIK you can't change the as2-to to AS2-To as this is the standard AS2 adapter behavior and as far as i see you have not changed any Adapter level code i.e patch you have just changed the connectivity details. So is this issue with only one Partner ? Was the issue existing before you made these changes ? are all partners connected to you have this issue ?

Br,

Manoj

Share
10 |10000 characters needed characters left characters exceeded