Skip to Content
0

RESTRICT CONFIRMATION IN EXCESS OR CHANGING IN UNITS

Jul 08, 2017 at 12:23 PM

159

avatar image
Former Member

DEAR ALL,

I want to restrict following problems:

In confirmation CO11N screen, user do confirmation more than GI Qnty.

Or User changes the uom from PC to KG and do more confirmation.

or User enter the amount to confirm and press goods movement tab, then press esc and then press save & system let him save the entry with the amount of pcs entered without checking anything

I want to restrict these three loop holes.

Pls Help out.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
avatar image
Former Member Oct 07, 2017 at 10:50 AM
0

Dear all,

Problem sorted out.

Thanks all.

Got abap coding in include to restrict the button functioning.

Thanks for your efforts..

Share
10 |10000 characters needed characters left characters exceeded
RAJA SEKHARA REDDY BANNURU Jul 08, 2017 at 01:39 PM
0

Hi
Confirmation Quantity in Excess & Shortages can be controlled by maintaining the Confirmation Parameters for the respective Plant & Order.
At the configuration level. Please take a look of the below setting for the same

If you maintain, this settings, the during the Confirmation of the Excess Qty, then the System wil though an Error message

Take a lok of the below example, with the Order : 60003876, with the Order Qty : 100
When trying to enter the Confirmation Qty : 101, ( Greater than the Order Qty: 100), you can see the Error message


jwhcx.png (52.6 kB)
aslvq.png (40.5 kB)
mykqq.png (133.7 kB)
Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Not working so far.

System allows the user to do confirmation in excess on above settings as my system currently working on the same.

0

Hi Sukhwider
Thanks for the kind feedback
If possible, Please share your current settings( Config & Master data)

What is the setting of Under delivery Tolerance & Over Delivery Tolerances values maintained in the Material Master , take a look of the below screen shot attached , with Master data & corresponding Production Order

Could you please take a look of the below Master data settings also ?

To restrict the Excess, your Material Master Data, Over Delivery Tolerance value should be ZERO.

Please maintain this & let me know your feedback/comments
Many Thanks for your quick feedback : Best Regards : Raja... Reddy

mljgw.png (117.9 kB)
0

Hi Sukhwinder Singh

After maintaining the Zero Tolerances, at the Mater data( Material Master- Work Scheduling view) & the respective configuration, does it works , to restrict the Excess Qty confirmation ?

Many Thanks for your valuable & kind feedback
Best Regards : Raja Sekhara Reddy

0
Former Member

Dear Sir,

thanks for showing your interest in this thread,

but it seems not worthy, when system gives an error, enter the amount you want to enter excess than GI amount, press goods movement button then press ESC then press ctrl+S system will save the confirmation.

0
shailesh mishra Jul 25, 2017 at 03:06 PM
0

Hello Sukhwinder,

Have you solved this problem? I find 2 issues in your questions.

1) Excess confirmation should be stopped. This is easy and can be achieved by OPK4 settings

2) Base UOM cannot be changed while doing confirmation in CO11N screen? right. I found a SAP note. But this is relevant for Warehouse management at time of Transfer order creation level when Base UOM could not be altered. This is done at material level and warehouse level.

2397490 - Change the alternative unit of measure determination in a TO item This note contains below information when settings are conducted at material level.
In transaction MM02 (change material), Warehouse Management View 1, please set the field "Proposed UoM frm mat" with value "N" (Base unit of measure, even if another UoM in reference doc). Do you find any field ''Proposed UoM frm mat'' in material master other than WM if you not using WM as I am not having access to system now.

Best regards

Shailesh Mishra

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Dear... Its not WM Scenario.

With OPK4 setting you cannot stop Excess Confirmation.

When system give error in Co11n screen, change the qnty, press goods movement tab & press ESC then save it. system will allow you to save.

0

please attach OPK4 settings screen shot. you can suppress the warning message into error which is getting triggered at time of confirmation.

0
Former Member

Sir,

I have already did the message turned into error.

But it allow the user to shift to goods movement tab & user saves it.

0