Skip to Content
0

Custom Entity attribute data not saved in standard table for MDG-M

Jul 06, 2017 at 10:34 AM

170

avatar image

Hi Experts,

We are facing an issue, that, we have made and custom entity ZZMAKTX for material description. Two types of SMT mapping mapping done like, STA & PP mapping, but still data not passing into standard table after finalize the Change request.

Please give some suggestion.

Regards

J Sen.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Jul 06, 2017 at 10:55 AM
0

Hi

Under which entity type you have added the new Z field? If it is description then you have to add 2 attribute. One main attribute and the other one is description.

Kiran

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Yes two entities one is under MATERIAL and another custom Entity ZMAKTX- ZZMAKTX attribute only.

0
Former Member

Why you have created entity type? You can add attribute under Material entity type itself.

Kiran

1

Hi Kiran,

Thanks for your helpful Idea. I am hereby elaborating the requirement.

Requirement

User is putting the description in Material description List UIBB along with maintaining different language codes, now this description is not going to show normal MM03, this description is regional specific. So, we have made a Custom table along with following attributes:

Material / Region / Description .

We are going to pass this description into Staging structure (this description we are not governing so, little bit rectify my previous comment we did not do any PP mapping for this), which we had made already. so once we made the STA SMT mapping for these three fields, system throws short dump Like that: variable protected in feeder-class level.

0

Please help with some idea, data also not saving in staging table.

0
Loga Nathan Duraisamy Jul 10, 2017 at 01:59 PM
0

Hi Jen,

  1. Make sure that MDG relationship and cardinality is correctly maintained.
  2. Make sure that data passed between Feeder class and Derive BADI.
  3. Check ST22 for any dumps
  4. If these are all fine, then issue might be with SMT mapping.

Thank you!

Share
10 |10000 characters needed characters left characters exceeded