Skip to Content

Archiving BWREQARCH RSMONMESS - Write Job only writes 10.010 entries

Hello,

my customer is archiving the rsmonmess entries into files using object BWREQARCH in Transaction "sara".

The write Job is working fine but it only writes 10.010 entires.

' 0 % ( 1 of 10.010 ) of SingleRequests archived KEN_01
' 100 % ( 10.010 of 10.010 ) of SingleRequests archivedKEN_01

I checked the Settings (sara -> customizing -> specific customizing there´s also a value for Maximum number of data elements. I increased the number to 100.000. File size Maximum is set to 70.000 MB.

Can somebody help me to increase the number when writing the entries to file? With 10.010 entries it will take ages to archive the entries...

Thanks!

Br,

Mario

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Jul 06, 2017 at 08:04 AM

    I think this is a default value which you can´t overwrite as a administrator anymore.

    My "workaround": First I sheduled a job to start with the write process after the Event "SAP_ARCHIVING_DELETE_FINISHED". This Event gets raised when the deletion process is done.

    Secondly I started a job to write the data and finally to delete it afterwards. This is a setting in the "customize" menu in transaction sara.

    Finally the job repeats as long as there is no data anymore to archive which meets your selection criteria in the variant you created.

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 05, 2017 at 04:17 AM

    Bump - can nobody help me out? Thx!

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 04, 2017 at 09:05 AM

    I found this document:

    https://uacp2.hana.ondemand.com/viewer/2e90b26cf7484203a523bf0f4b1bc137/7.40.15/en-US/4a7047ca606972e0e10000000a42189b.html

    During an initial archiving, the administration data of at most 10,000 requests that meet the selection criteria are archived per archiving session, and then deleted from the database. If archiving is periodically scheduled, archiving is executed for 10,000 requests each time until the administration data of all the old requests is archived. After this, an archive file is only created when a specified minimum number of requests has been reached.

    It seems that this is a standard limitation -but I´m pretty sure that I can change this value somewhere. Have found other SCN discussions with 80.000 entries archivied...

    Any ideas?

    Add comment
    10|10000 characters needed characters exceeded