Skip to Content

Crystal Reports 2013 and SAP BO 4.2 sp4

Jul 04, 2017 at 12:54 AM


avatar image

I am trying to open a Crystal report that was upgraded to BO4.2 sp4 with Crystal 2013 and I am getting an Internal Error. Is Crystal 2013 incompatible with BO 4.2?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Vitaly Izmaylov
Jul 04, 2017 at 06:07 PM

The version 4.2 is compatible with Crystal Reports 2016.

V4.0 = CR 2011

V4.1 = CR 2013

V4.2 = CR 2016

You do not need a full reinstall, you can simply update it.

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Hi Vitaly,

We recently upgraded from 4.1 SP5 to 4.2 SP4. I cant open crystal reports in BI Launchpad. You said 4.2 is compatible with crystal reports 2016. When you said "simply update it", do you mean to update 2016 crystal client tool? our client tools are on seperate server. should we install crystal 2016 on our BO server? Or Do you mean open report using 2016 crystal tool and update it in BI Launchpad?

Kanthirekha Kasavazala

If reports were working on 4.1 Sp5 they will work in 4.2 SP4.
If those same report are not working - then something went wrong and it needs to be investigated.
It could be issue with upgrade or something else.

Kanthirekha Kasavazala
I agree with Denis, it should be investigated.

Is it single report issue or all reports affected?

Is it just "Internal error" or there are more details?


However, you will need to have the latest SP of Crystal 2016 in order to connect to your BOBJ system from Crystal due to some major changes in the crypto and C++ libraries with BOBJ 4.2 SP4. See for more info.