Skip to Content
avatar image
Former Member

Web Dynpro in Internet Explorer vs Firefox

Hi Experts,

We created a Web Dynpro with an application and views as per usual.

Everything looks fine in Firefox (2.0), but when running the Web Dynpro through Internet Explorer 6.0 there are a lot GUI bugs (elements not being aligned, the right length, etc.)

Is there any way to fix this, we didn't do anything 'strange' in our layouts?

Thanks,

JP

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    May 23, 2007 at 03:40 PM

    Hi JP,

    Different browsers behave differently no doubt about that, this is not the case with webdynpro but it's even with simple html as well. <b>for example</b>: drop down in html looks different in IE, Opera and firefox that means even simple html tags behave differently, so it's not a problem with the tag but with the browser and there may be diferent reasons why browsers are programmed to behave that way.

    Similarly alignments may behave differently in different browsers. So it is always recommended to test your view in different browsers.

    Tip 1: Matrix Layout is recommended

    Tip 2: Use Transparent Containers over Groups

    Tip 3: first adapt your UI elements for Internet Explorer 6.0 or higher, when you are done with alignments then test the same on firefox.

    Best Regards,

    Amol Bharti

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 23, 2007 at 03:59 PM

    That sounds strange as my experience is that Web Dynpro applications look better in IE than in Firefox. Perhaps the style sheets are not correctly loaded? Is the applicationrunning inside the Portal?

    Armin

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Thanks Armin, before doing that I'd just like to make 100% sure it's not just something on our side. We tried running the app in a different minor version of IE 6 and received this error:

      Line: 18
      Char: 8606
      Error: 'style' is null or not an object
      Code: 0
      

      Is this a stylesheet problem?

      If so, how can we try and fix it?

      If opening an OSS note is the only way to go, I'll do that a bit later today.

  • avatar image
    Former Member
    May 23, 2007 at 02:18 PM
    Add comment
    10|10000 characters needed characters exceeded