Skip to Content
0

Error BPC 10.1 "Hierarchy ***** does not exist in BPC"

Jul 03, 2017 at 04:53 PM

235

avatar image

Hi experts,

These are my BPC version and SP level and I have EPM 28.3 in Office 2016:

SAP_BW: 740 SP15

CPMBPC: 810 SP10

I am facing with an error during the import of hierarchy ZHIER_CC from infoobject 0WBS_ELEMT. I managed to import master data succesfuly with the first package /CPMB/IMPORT_IOBJ_MASTER.

I have read a lot of threads about my error, but it was not helpful for me.

When I am uploading second package /CPMB/IMPORT_IOBJ_HIER, it fails with the next log:

My BPC dimension is PROYECTO. It has three hierarchies into its structure (PARENTH1, PARENTH2, PARENTH3)

This is my hierarchy in BW side. This 0WBS_ELEMT has 4 hierarchies,

I am using these transformation file and conversion file:

*MAPPING NODENAME=NODENAME HIER_NAME=HIER_NAME PARENT=PARENT ORDER=ORDER


*CONVERSION NODENAME=PROJECT_CONV_HIER1.xls!NODENAME HIER_NAME=PROJECT_CONV_HIER1.xls!HIER_NAME PARENT=PROJECT_CONV_HIER1.xls!PARENT

In NODENAME sheet of conversion file, I have:

* js:%external%.toString().replace(/ /m,"_").replace(/ /m,"_").replace(/ /m,"_").replace(/\u0027+/g,".").replace(/\u0028+/g,"-").replace(/\u0029+/g,"-").replace(/\u002C+/g,".").replace(/\u002F+/g,"-").replace(/\u002B+/g,"&").replace(/\u003A+/g,"-").replace(/\u0022+/g,"."). replace(/\u003B+/g,".")

When I validate the transformation file shown above with the hierarchy infoobject 0WBS_ELEMT, I get a correct result.

When I run the package /CPMB/IMPORT_IOBJ_HIER, this is my set selection and the hierarchies does not have versions.:

Here you can see P_1656-000 is a node and not a hierarchy

I have tried differents ways to run the package of hierarchy. With overwrite, update, internal, external...all combinations. I get the same error always.

I would appreciate any help of you.

Kind regards,

Leandro

log.png (18.7 kB)
hier.png (13.9 kB)
hier1.png (32.8 kB)
hier2.png (7.2 kB)
node.png (13.2 kB)
hiername.png (8.4 kB)
parent.png (8.8 kB)
ok.png (124.3 kB)
paquete.png (8.5 kB)
mix.png (54.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Leandro Garrigós Domínguez Jul 04, 2017 at 07:45 AM
0

Hi Vadim,

Thank you for your quick response. Sorry for my log, but I couldn't get an english log. The log translation is as follows:

Task name HIERARCHY DATA SOURCE:

Info: Hierarchy node includes text node or external characteristics

Record count: 1651

Task name CONVERT:

No 1 Round:

Reject count: 0

Record count: 1651

Skip count: 0

Accept count: 1651

Task name HIERARCHY DATA TARGET:

Error enconuntered in the sysem

Hierarchy P_1656-000 does not exist in BPC

I have changed the nodename tab in conversion file, but I got the same error:

Kind regards,

Leandro


log.png (18.7 kB)
nodename.png (13.9 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Sorry but I am unable to check on your system how you get this missing member...

0
Vadim Kalinin Jul 03, 2017 at 06:24 PM
0

Sorry, but if you provide not English log you have to translate each line!

Node name conversion file is strange: if you have * in the first line then only this first line will be processed (only single line of conversion file is processed if condition is matched).

Share
10 |10000 characters needed characters left characters exceeded