Skip to Content
0

Value Help Data is not getting Updated?

Jul 02, 2017 at 04:23 AM

60

avatar image

Hi Experts,

I am working on the Custom SAPUI5 application to create Stock Transfer Order. In My application , i am having two value hep input filed (Please refer the image below ). Plant and Materiel List.

While loading at first time, i am able to see the Plant list and material list correctly. Material list should loaded the based on the plant what we chosen from the plant value help. i am forming the filter and setting it dynamically inside my material dialogue fragment.

But in the Second time, after pressed the add button , if i select different plant from the palnt list , material list is not getting updated. it is displaying the same material list for the first selected plant.

while debugging, filter it is getting changed but in network tab no request has been formed.

Please help me on this.

Thank you,

Regards,

JK

screen1.jpg (26.2 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Jul 04, 2017 at 11:37 AM
1

Hello Jayakrishnan,

Where you are applying the filter for material?

i think you need to apply the filter for material on selection change event of plant value help field and clear the value of both the fields (that is plant and material) on add button press.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jul 04, 2017 at 01:39 PM
0

Hi JK,

Try to create a dynamic query with filter attribute ($filter) and bind it to the value help for material field. Also, verify if your association is working fine between your entity sets for plant and material and filter is working fine in your back end from where your material values are populating.

-Regards,

Ketan

Share
10 |10000 characters needed characters left characters exceeded