Skip to Content
avatar image
Former Member

PowerBuilder SyntaxFromSQL issue

We are migrating our Sybase ASE 12.5.4 database to a new server. When we run one of our PowerBuilder 10.2 applications on the new server, it fails. The reason is because that when we call SyntaxFromSQL we get a different syntax returned. When the app uses the existing database, the column definitions returned by the SyntaxFromSQLncall include the table name.

column=(type=long updatewhereclause = yes name=<table name>_<column name> dbname="<table name>.<column name>")

When we call the new database, we do not get the table name.

column=(type=long updatewhereclause = yes name=<column name> dbname="<column name>")

The query is a multi table query if that makes a difference.

We could change the code, but we would rather not go thru our whole release process. Originally the PowerBuilder extended attribute tables did not get copied over, so I thought that might have been the issue. We created them by logging into the database thru PowerBuilder using a user with SA rights to create the tables. That did not change anything. We then refreshed the database making sure the extended attribute tables were included but we still have the issue. Does anyone know what is causing this difference? Does it have to do with extended attributes table? Or something else? Thanks for any help.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 05, 2017 at 02:11 PM

    One of our developers found the problem. One of the databases did not have the views moved from the old server to the new server. The view wasn't directly used in the syntax returned by the SyntaxFromSQL call so I don't know why this was causing the syntax difference. But its fixed.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 03, 2017 at 02:08 PM

    Are you actually running the app on the server? The app only talks to OpenClient so if you were to connect from a desktop pc to both old/new servers they should work the same.

    Try running trace mode against both servers and compare the commands in the two log files.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks for the response. The app runs on a user's desktop or within a Citrix environment. Both environments produce the same result. I tried the trace mode like you suggested but it only showed the connection to the database and nothing after that.