Skip to Content
0

JDBC Sender Connection how to close it

Jul 04, 2017 at 10:52 AM

139

avatar image

Hi,

We have recently developed some new JDBC connection interfaces, and I am having problems getting the pick up to work properly. We are on PI7.1

We have the config in Dev and QA (not in prod yet). Given the 3rd party database limitations, we point both our Dev and QA connections to the same connection string.

Trying to run stuff through our QA environment, I am finding that our Dev connection picks it up instead. This is despite the Dev channel being closed, and the status of the channel (JDBC sender) being set to INACTIVE on the advanced tab in IB (this last change was done as just closing the channel didn't stop the pickup).

I also think there is a problem in the QA environment with the JDBC adapter, as, I got it polling yesterday, but it now says "processing error in the last 24 hours", and it stopped polling soon after I got it started.

I have googled stuff, and some old blogs talk about using Visual Admin to monitor JDBCs, but basis tell me they don't use that for PI. Our Basis are as new to JDBC stuff as I am for PI.

Can someone give me some pointers on

a) why Dev still picks up

b) how to investigate and fix any JDBC adapter type errors on the system, for our version of PI.

Thanks

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

7 Answers

Best Answer
Elizabeth Stapleton Jul 07, 2017 at 11:47 AM
0

Hi

thank you all for your valuable input. I have learned a few good things to do whilst checking for errors here.

Ultimately, I do not know what fixed it....but it is now fixed.

After a restart of our Dev database, my QA interface is doing what it should, and my dev interface isn't getting in the way.

Many thanks

Elizabeth

Share
10 |10000 characters needed characters left characters exceeded
Evgeniy Kolmakov Jul 04, 2017 at 01:10 PM
2

Hi Elizabeth!

You could try to restart "XPI Adapter: JDBC" service. But your channel should be stopped by setting Status to "Inactive" in CC properties or as Inaki has already suggested in Communication Channel Monitor.

Regards, Evgeniy.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Evgeniy,

Thank you for the suggestion. I have stopped/started XPI Adapter:JDBC service on both Dev and QA, just to make sure. The latest scheduled drop off of data at the database end resulted in the same result. The data came through Dev. I have closed ALL my dev channels in readiness for the next timing. Just to check that off the list.

Thanks Elizabeth

0
Iñaki Vila Jul 04, 2017 at 12:47 PM
1

Hi Elizabeth,

Have you tried in your DEV to stop the channel directly from communication channel monitor?

Regards.

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Inaki,

Yes I have closed the channel in RTWB in dev by setting the status to stopped.

Following on from other comments below, I have now also changed the connection string in Dev, so it should fail. However, the latest scheduled pick up, still happened through dev. Something odd going on.

Thank you for your assistance

Elizabeth

0

Elizabeth check the cache status once, Might be the changes are not getting reflected.

0

Hello Raghuraman,

I have just checked sxi_cache for PI on dev and QA. They are both green, and saying the content is up to date.

Thanks for your suggestion.

Elizabeth

0
Manoj K Jul 05, 2017 at 01:53 PM
1

Eliz,

Just to dig a bit mention a wrong server name in your DEV channel , and then check if the pick is still happening from Dev. or Delete and Re-create a new channel and keep it inactive while activating.

By doing this you can actually check if the change is reflecting or PI is still taking the old changes.

Br,

Manoj

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Manoj,

Using the wrong server name made no difference. I will try deleting the dev channel entirely next.

It is interesting (?) that everything seemed to be working fine in our QA environment up to Monday 26th June.

No-one can think of anything un-toward that happened on that day.

Many thanks.

Elizabeth

0
Raghuraman S Jul 04, 2017 at 01:04 PM
1

Making the channel inactive should fetch any data from JDBC.

Check the option mentioned by Inaki,Also check in the CC monitoring if that channel is only picking the data, Might be some other channel that points to the same DB might be trying to pick the data.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Hi Raghuraman,

Yes, the CC is off in RTWB. In fact, just to make sure I have switched off all channels in Dev. It didn't make any difference. I'm still working my way through the other suggestions below.

Thank you for your assistance.

Elizabeth

0
Nidhi Srivastava Jul 04, 2017 at 01:33 PM
1

Hi Elizabeth,

It seems there is conflict issue as your DEV and QA are pointing to the same string.

What I understand that both the channels are looking for the same connection and hence it is not working.Try deleting one of the channel and then use one at a time, that will reflect for the actual issue.

Also, perform a cache refresh once.

Thanks,

Nidhi

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Nidhi,

Thank you for your assistance. I have done the following things to try and track this down:

Stopped and Started the XPI Adapter: JDBC service in both Dev and QA

Closed all of my Dev channels in RTWB (even ones that aren't related to this interface :))

Edited my Dev connection in the JDBC adapter and made it invalid.

On both Dev and QA set to "disconnect from database after processing each message". It sounded useful.

Refreshed all caches to full, on Dev and QA via NW Administration/Data Cache Overview

Closed all of the QA channels for this interface (and others for the same project, in case I missed one).

The pickup still happened.

How can a connection be made via JDBC adapter through any SAP system, without channels?

The person who configured all this has left, and done no documentation, otherwise I'd be able to ask them.

To be honest we are starting to get concerned over the Prod JDBC interface we have, not switching off properly when we do patching.

Thank you all for your input.

Elizabeth

0

Hi Elizabeth,

You have done a good work. I have two questions, only to discard the obvious:

1. Are you sure the channel that you try to stop, it is really picking the registers?, i mean have you seen in the monitoring the message?.

2. You said, "the pickup is done", how you know this?, you have your ECC DEV with the data or your only go to DB and check the flag of the pickup marked?

Regards.

0

Hello Inaki,

Yes, I have 2 messages processing in our dev system....PI SXMB_MONI etc. We have a JDBC Sender into ECC to post, which triggers a second abap process which initiates an outbound JDBC Receiver connection, to the database.

In frustration and to prove a point I have closed every single one of our Dev channels, and the same for our QA channels - for all interfaces we have.

Guess what, the 2 messages still triggered, at the allotted time (the database writes to its pick up table every hour).

Thanks for your help

Elizabeth

0
Nidhi Srivastava Jul 06, 2017 at 06:14 AM
1

Hi Elizabeth,

It seems you tried almost all the options.

I have a feeling that some other channel or connection is picking up the same. If the person who configured left, please check other channels in your landscape. May be some other channel is having the same connection as you have configured.

Thanks,

Nidhi

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Hi Nidhi,

I have closed all of our channels, for all of our interfaces in both Dev and QA.

Guess what :)

I still get the dev interface happening every hour.

Thanks

Elizabeth

0

Elizabeth,

By chance the channel is controlled by ATP?

0

Hi Raghuraman,

sorry what is ATP? thanks

0

No, got it, Availability Time Planning....no, we don't use those in dev and QA only prod.

Thanks

0