Skip to Content
-1

SAPINST_START_GUI and modlib.jslib issue

Jul 02, 2017 at 07:14 AM

539

avatar image

Hi All,

I was working on S4HANA personal system and earlier everything was working but all of sudden it stopped working now.

Latest status as of now - installation failed with modlib.jslib.Caught exception error

Previous status -

It is giving error as per screenshot and earlier process list turned to "Grey" and now it is giving error like this.Seems I have screwed it more.

I tried to install S4HANA hana then also it is giving error.

Please suggest with list of steps to be followed.

Thanks & Regards,

Praveen

capture.jpg (18.4 kB)
58395-capture.png (86.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

7 Answers

Best Answer
Praveen Singh Sep 22, 2017 at 02:06 AM
0

This was trial system validity issue.

I have fixed it and now system is up and running.

Thanks,

Praveen

Share
10 |10000 characters needed characters left characters exceeded
Michael Healy
Jul 02, 2017 at 09:33 AM
0
Show 8 Share
10 |10000 characters needed characters left characters exceeded

Hi Michael,

I am facing issue in re-installation of SAP S4HANA.

Could you please advise?

Thanks & Regards,

Praveen

issue.jpg (37.2 kB)
0

Can you upload the installation file

0

Hi Michael,

Which installation file you are asking for?

Can you tell me more about it?

Thanks & Regards,

Praveen

0

The log files in /tmp/sapinst_instdir

0

Hi Michael,

Sorry for delayed response.

File is too big to upload.

I think, main problem is that process list is not up and there is no status for it.

Please advise.

Thanks & Regards,

Praveen

0
0
Show more comments
Michael Healy
Jul 21, 2017 at 03:14 PM
0

Hi,

I looked into the files. Are these files from your Sybase system? I see no relevance to HANA in the files.

The files constantly reference SYBASE?

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Michael,

I am using this SAP S4HANA Implementation for installation.

Please let me know how to solve this issue.

Regards,

Praveen

0

Hi,

The issue here is not related to HANA so I would advise you either to try posting in the netweaver / application forums or open a ticket with SAP (not sure if this one is an option for you)

0

Sure.Thanks!!

0
Praveen Singh Jul 31, 2017 at 12:39 PM
0

Hi,

Changing the group to "Netweaver".

capture.png

Please suggest as I tried to install SAP S4HANA many times.

Thanks,
Praveen


capture.png (86.4 kB)
Share
10 |10000 characters needed characters left characters exceeded
Reagan Benjamin
Aug 01, 2017 at 02:36 PM
0

From where did you download the installation files? From the screenshot I can see it is throwing an error at the checkSybaseUser phase but you mentioned that you are installing S/4 HANA. If you have downloaded the right installation files then I suggest you delete the old installation files and cleanup the /tmp/sapinst_instdir and start the installation once again. If the installation fails come back with the logs from the /tmp/sapinst_instdir directory.

Show 5 Share
10 |10000 characters needed characters left characters exceeded

Hi Reagan,

I have downloaded files from SAP Development tools site i.e. https://tools.hana.ondemand.com/#abap

I was able to install S4HANA system very first time but because of some issues I tried to install again but I am unable to install.

Could you please help me with steps to clean up /tmp/sapinst_instdir directory (also previous SAP installation on virtual machine) as I don't have much experience in openSuse commands?

I will try to install again.

Thanks,

Praveen

0

Stop sapinst. If possible restart Linux. Rename or delete the sapinst_instdir. Start the installation once again.

0

Hi Reagan,

I have tried your suggestion but still SAP installation is failing.

Please suggest.

Thanks,

Praveen

capture.jpg (97.3 kB)
0

Provide the space available on the file systems

The screenshot is useless. You need to supply the logs from the /tmp/sapinst_instdir/NW73/SBC/STANDARD location

0

I have deleted all sap installation including tmp and sapmnt folders and the tried to run installation again but issue still exist.

Please suggest.

Thanks,

Praveen

0
avatar image
Former Member Aug 01, 2017 at 08:58 AM
0

Hello Praveen,

Is it a java only system installation?

1.Check whether sapstartsrv of the affected instance is running.
2.If sapstartsrv is not running, start the sapstartsrv as a deamon with <sid>adm user using the following command: •sapstartsrv pf=<instance profile> -D

Also check note #2260552 - NIECONN_REFUSED Error in Java Instance install

Regards,
Manjunath Hanmantgad

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Manjunath,

I am facing in initial installation itself using this link.

It is not reaching point 10 in Step 5 of this link. (Install SAP Netweaver AS ABAP on Linux VM).

I am using password properly.

Please suggest.

Thanks,

Praveen

0
Former Member

Hello Praveen,

Paste the sapinst_dev.log here for checking.We can find some more information in that.

Regards,
Manjunath Hanmantgad

0
Praveen Singh Sep 04, 2017 at 12:45 AM
0

Hi Guys,

I believe,the S4HANA which I am trying to install will work with OpenSUSE 42.1 (we are unable to install UUIDD components) but because of recent upgrades of OpenSUSE 42.2,42.3 we are unable to install S4HANA on system.

I will be glad if anyone from @moderator will guide us with latest version of OpenSUSE or redirect to correct forum.

SAP S/4HANA System Setup

Thanks,

Praveen

Share
10 |10000 characters needed characters left characters exceeded