Skip to Content
avatar image
Former Member

When assigning Business Role in access requst, It cannot find one of the role in ECC system

I created Business role, it had three composite roles.

I created one more composite role in DEV ECC and transported into QA ECC and Prod ECC systems. I did role import and added new composite role in Business Role.

When I provision Business role through GRC, it provision three roles in QA and PA system but not provisioning new composite role. However, in DEV system it provision all 4 composite roles correctly.

I ran full Sync Repository Job in GRC for QA system and tried import again and removed new role and added again in Business Role. But I am still getting same error message that 'Composite role does not exist in QA system'.

Can anyone please advise what I am doing wrong.

Error message in Audit log says that YSTANDARD-ECC (composite role) does not exist in system QA. It does create and assign roles in DAR and QAR but only one role goes missing.

hzqfq.png (35.0 kB)
b6q3d.png (36.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jul 05, 2017 at 04:28 PM

    Masood,

    Did you run Auth Sync & Role Sync in QA,Did you pull the composite role to BRM(Role Import).I think if you use provisioning step in the Business Role Methodology, it should solve these issues.

    Thanks

    Ramesh

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 06, 2017 at 09:27 AM

    Hello Masood,

    How have you imported Composite role in BRM? What was the authorisation source (was it skipped) ?

    Please check if the methodology for Composite role "Complete" in BRM. What happens when you try to provision only the composite role directly ?

    Kind regards,

    Yashasvi

    Add comment
    10|10000 characters needed characters exceeded