Skip to Content
avatar image
Former Member

ROS Questionnaire link sent by email

Dear All,

I request some piece of information from you.

Following is the problem scenario:

The customer has 2 surveys :-

a) SurveyA questionnaire QuesA :-

the system sends the email with the link to the questionnaire (without enclosed file) and asks for a userid and password from the supplier when he tries to access the link in the mail.

If the supplier enters the ROS system userid and password, he can view the form, fill it and submit it.

The questionnaire is visible in the preselected vendor list.

b) Survey B, questionnaire QuesB

The system sends the email with enclosed questionnaire.The supplier can view the form, fill it and submit it.The questionnaire link is not visible in the preselected vendor list.

The customer has 2 queries:-

1) What setting difference is there between the 2 questionnaires that the system sends for one, an email with a link to the questionnaire and for the other, the questionnaire enclosed in the email.

2) Why does the questionnaire ask for userid and password from supplier when he tries to access the questionnaire via the link in the email?

Kindly advise on the above queries.

Thanks and regards,

Krithika

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    May 17, 2007 at 01:07 PM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 17, 2007 at 05:31 PM

    Hi Krithika,

    1. the difference is, that for one questionnaire the option "Direct Update in Application"

    is selected. You can check the settings for each questionnaire on the header

    level. With direct update the user is login into the application and does the

    questionnaire online.

    2. For online fillout the user directly access the application. You should turn off

    the login, by setting a anonymous login on the BSP service file.

    Check the settings for SAPconnect. It seems, that there are some elements missing,

    when the sent back of the questionnaire does not work. Check SO50, the profiles

    of the SAPconnect user etc.

    Hope that helps.

    Thanks,

    Claudia

    2.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 27, 2007 at 12:29 PM

    Dear All,

    Please find below the answer to my query :-

    The decision of sending the questionnaire as a link or as an attachment

    depends on the 'Covering letter'.

    If you create a 'Covering letter' in the survey cockpit and this

    'Covering letter' contains the string '/URL/' this string will

    be replaced by the URL of the BSP-Application UWS_FORM_SERVICE,

    if you send the questionnaire to the recipient.

    If you have no 'Covering letter' the questionnaire is sent as an

    attachment and also in the mailbody.

    If the 'Covering letter' doesn't contains the string '/URL/'

    but any other text the questionnaire is send as attachment

    and the mailbody contains the text of the 'Covering letter'.

    If you send the questionnaire as a link, the BSP-Application

    UWS_FORM_SERVICE is used to display the questionnaire in

    the browser. If you start this BSP Application you get a logon popup.

    This is the normal behaviour if you start a BSP Application.

    Thanks and regards,

    Krithika

    Add comment
    10|10000 characters needed characters exceeded