Skip to Content
avatar image
Former Member

Field "Generated on" in alerts monitor

Hi!

When i generate an alert for a selection at 4:00 PM, in the alert monitor, the alert appears but its field "generated on" is false. Indeed, it's written 2:00 PM. In fact there is always a 2 hours gap. I check sy-uzeit and it's ok (i.e. 4:00 PM).

Do you know why? Can i correct this field?

Thanks by advance,

NB: In an abap program I read all alerts and i must check the hour that's why the field "generated on" is important in my case. Of course the problem is solved if i add 2 hours myself (in the prgm).

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    May 14, 2007 at 11:04 AM

    hi can you check if you can change the setting in the alert monitor for the time zone

    this will be under environment-- > time zone for display. you can try to match these with the time zone you expect.

    also what kind of alerts are these? i wonder if your SNP time zone settings in planning version display is set to local time zone?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 14, 2007 at 11:06 AM

    also is your local time zone UTC plus 2?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      In fact i need to compare to hour. The first one is the field "generated on" from alert monitor (UTC) and another one in a z table. In this tabe the filed hour is fill by sy-uzeit = UTC + 2 in daylight saving time or UTC + 1 (CET).

      I find a solution:

      I use FM /SAPAPO/DATE_CONVERT_TIMESTAMP with the hour from my z table. I give it the date and the hour. This FM returns a timestamp in UTC.

      So i have two UTC hours and i can compare them.