Skip to Content
avatar image
Former Member

[HELP] Error after upload the BRM roles

Dear all,

We ran through an awkward situation on my current project. We tested successfully the upload files for Single Roles, Composite Roles and Business Roles successfully at the our Dev Environment.

However, after import it and go the provisioning tab at PRD, we had the message "Invalid Role Name an Landscape combination. Make sure the role exists in the given landscape".

Due to this error, every time we try to assign a business role to a user, the system ran into a Dump TABLE_INVALID_INDEX.

We know for sure (we tested) that if we create a role within BRM, and assign this role to the user, the dump does not occur.

We had tested the upload file with different layouts, with no success. We also tried to import roles using the server functionality but although some roles were imported correctly and does not had the problem, most of then had it.

The same error occur with our composite roles.

Additionally, although we only will make the provisioning to our PRD system, both PRD and DEV appear at the provisioning tab.

The SLG1 shows no information regarding it.

Had anyone ran into the same situation? Does anyone know what can I do to fix this?

What we had tried so far:

==> Check Authorization for the connection users at connected systems

==> Check Connector configuration

==> Check scenario - Connector

==> Check default connectors

==> Performed Synchronization Jobs

==> Upload the files with different layouts

Our solution is SAP GRC Access Control 10.1, SP17

Best Regards,

Caio

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 03, 2017 at 08:37 PM

    Hello All,

    By the end of our analysis we concluded that we had an inconsistency generated by some information at our first upload. This lead some roles to be sort of locked at a database level. We erased all the upload and after we went to the table and with the debug mode, manually deleted the entry.

    So, we have corrected the upload file and reperformed the upload.

    So far, the issue seems to be resolved.

    best regards,

    Caio

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 28, 2017 at 06:52 PM

    Hi Caio,

    From the screenshot above I can see the TR exists in Development and Production,are you importing BR with TR from DEV and PRD?If so do you have the connection scenarios for DEV?

    Thanks

    Ramesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      i Ramesh, thanks for your answer.

      I believe that the integration scenarios are good. There is some screen capture of them, but if anything is wrong please tell me.

      We think that the upload program might been performing some bad upload. As far as we know, after deleting and re-importing roles from to the PRD environment, there is some roles (lower amount than our first upload) that still give us the same error. We believe that roles with the Infrastructure error, is not considered as "Ready" by GRC. That's why if we create a business role manually, these bugged roles does not appear to be selected, GRC must have some validation avoiding it. But when we upload it, is like we've been forcing a business role creation with these bugged role.

      So, when we go to the ARM to request the BR with the bugged roles on it, we have a Dump, so I believe that the dump is a consequence.

      We were running a few theories in here:

      ==> It could be some language problem. when we log on English, the status description does not appear. This is just a long guess, based on one error we had at the EAM template message which we had to provide the translation to English in order to make it work, although our implementation is occurring at Spanish language (our client is from Central America)

      ==> It could be some file format. But we have no error when we upload it

      Or

      ==> Programming error from the SP17.

      Best Regards,

      Caio


      2017-06-28-14-24-13.png (21.2 kB) 2017-06-28-14-25-56.png (18.6 kB) 2017-06-28-14-24-13.png (21.2 kB) 2017-06-28-14-26-42.png (19.7 kB) 2017-06-28-14-27-35.png (18.1 kB)