Skip to Content
0

BPC NW: Process Dimensions File Delete and Reprocessing. Hierarchies Changes with Long Run Time

Jun 27, 2017 at 09:52 PM

72

avatar image

Hi All,

I have delete the my dimension file in UJFS and re created. then the hierarchies data on PARENTH1,PARENTH2 and PARENTH3 data is gone. So when i manually adjust the PARENTH1 and H2 the Process dimension is taking much time to run for less data. I have 4000 lines where in i have to maintain the PARENTH1,PARENTH2 and PARENTH3.

Is there any other way to do this?

There are Many SQL statements running in background. it trying to re-create indexes every time i process few lines of hierarchies. Will that happen every time when we process hierarchies?

Thanks in Advance,

Manoj

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Vadim Kalinin Jun 27, 2017 at 09:59 PM
0

"I have delete the my dimension file in UJFS and re created." - not clear, what are you doing! Strange idea to delete something in UJFS.

You can export dimension to text file, perform required adjustments in it and then import back using standard DM processes.

4000 lines is not a lot!

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Thanks for your response Vadim.

Just to clarify - We are in BPC 7.5 NW. A user deleted all the members in the member sheet for "Site" dimension in our planning application and processed the dimension without taking the system offline. This proceeded to fail. After this we tried to restore the backup copy in the admin client. However, now the processing takes many hours to run and we only have about 4000 members in it. We tried running master data loads and it fails every time we try to import the site hierarchy. So we decided to directly import the site dimension backup into UJFS by renaming the existing file to site_old.xls and importing the new file in its place. This does not solve our problem either as still the processing takes hours and eventually times out and fails.

We checked sm50 while processing the dimension and the process seems to be running some kind of a massive SELECT statement taking all the dimensions in the application. It's also trying to create indexes every time. Is this normal?

The site dimension contains three hierarchies. We started processing the PARENTH1 hierarchy 20 lines at a time and it takes 15-20 minutes to process each time but succeeds at least. But doing this across 3 hierarchies and for 4000 members would take too long.

We ran UJA_DATA_CHECKER program and we did not find any errors either except for missing journal tables but we do not use journals. We also tried refreshing dimension cache from UJRD and increasing the template versions while uploading the dimension files in UJFS and this did not help either.

Is there anything that we can do to troubleshoot this? Processing a dimension usually is very simple and takes less than 5 minutes for this particular dimension. We are not sure if there is anything corrupted?

0
Manoj Reddy Bhimireddy

Please talk to basis team to perform server checks!

0