Skip to Content
0

Hana SQL port is inactive

Jun 27, 2017 at 07:21 PM

239

avatar image
Former Member

Dear Experts,

I apologize, if this is a silly question, but I just finished my first Hana installation,
and I determined, that I am unable to connect with hdbsql and I also guess then,
that when I install Hana Studio, I won't be able to connect with it either:

hdbsql=> \c -i 00 -n Han -u SYSTEM -p <mypwd>
* -10709: Connection failed (RTE:[89006] System call 'connect' failed, rc=111:Connection refused (<hostname>:30015))

I've checked with netstat and also with telnet localhost 30015 and there is nothing listening on this port. It's not even recorded in /etc/services.

Please kindly advise what am I missing ??? Many thanks in advance!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

avatar image
Former Member Jul 03, 2017 at 10:31 PM
-1

Come on, nobody has an idea ? I can't even install Hana Studio, as I won't be able to connect if the SQL port is not running :-(

Share
10 |10000 characters needed characters left characters exceeded
Frank Schuler
Jun 28, 2017 at 05:30 AM
0

Hello Symon,

This sounds as if your HANA instance number was either not 00 or your system is not fully up. What does HDB info show you?

Best regards

Frank

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jun 28, 2017 at 09:05 PM
0

Hallo Frank,

many thanks for your answer, however what you're saying is not so good.
I hope there will be an easy fix. Here is the output that you've requested:

$ HDB info
USER PID PPID %CPU VSZ RSS COMMAND
<SID>adm 2176 2175 0.0 116180 4168 -bash
<SID>adm 2984 2176 0.0 113264 3092 \_ /bin/sh /usr/sap/<SID>/HDB00/HDB info
<SID>adm 3021 2984 0.0 151076 3728 \_ ps fx -U <SID>adm -o user,pid,ppid,pcpu,vsz,rss,args
<SID>adm 2384 1 0.0 23056 3192 sapstart pf=/usr/sap/<SID>/SYS/profile/<SID>_HDB00_<hostname>
<SID>adm 2392 2384 3.0 598600 318596 \_ /usr/sap/<SID>/HDB00/<hostname>/trace/hdb.sap<SID>_HDB00 -d -nw -f /usr/sap/<SID>/HDB00/<hostname>/daemon.ini pf=/usr/s
<SID>adm 2412 2392 83.2 5840248 3369748 \_ hdbnameserver
<SID>adm 2571 2392 35.6 3124976 709484 \_ hdbcompileserver
<SID>adm 2573 2392 5.8 2924572 562008 \_ hdbpreprocessor
<SID>adm 2614 2392 144 9668504 6896172 \_ hdbindexserver -port 30040
<SID>adm 2916 2392 19.3 3241480 790128 \_ hdbwebdispatcher
<SID>adm 1613 1 0.4 499776 32832 /usr/sap/<SID>/HDB00/exe/sapstartsrv pf=/usr/sap/<SID>/SYS/profile/<SID>_HDB00_<hostname> -D -u <SID>adm

Share
10 |10000 characters needed characters left characters exceeded
Sadiq Iqbal Jul 14, 2017 at 12:48 PM
0

Hi

try this on OS level

hdbsql -d SID -u SYSTEM -p Password

run the query to get correct port

SELECT SERVICE_NAME, PORT, SQL_PORT, (PORT + 2) HTTP_PORT FROM SYS.M_SERVICES WHERE ((SERVICE_NAME='indexserver' and COORDINATOR_TYPE= 'MASTER') or (SERVICE_NAME='xsengine'))

Thanks

Sadiq

Share
10 |10000 characters needed characters left characters exceeded