Skip to Content
2

[Bug or Feature] Filter options for q&a list disappear when no result is found

Jun 27, 2017 at 09:11 AM

202

avatar image

Hello there,

so I'm using the nifty filter option "Followed tags" a lot.

.

Since it's not yet possible to filter for several tags at once I tend to click through my tags one after another to see the content for it.

.

The issue is: When there is no result for a tag, the filter options on the right side disappear. Then it looks like this:

Now I have to use the mega menu or the (new) bread crumb entry to get to the q&a list again to get my filters back.

When there is a result for my filter, the filters stay and I can easily change to another one:

.

So is this on purpose? Is this a bug? Help?

.

Regards,

Steffi.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Vadim Kalinin Jun 27, 2017 at 09:24 AM
0

Looks like a bug!

"Now I have to use the mega menu or the (new) bread crumb entry to get to the q&a list again to get my filters back"

Just use Back key to return to previous page :)

Show 9 Share
10 |10000 characters needed characters left characters exceeded

You mean leave my mouse and move to my keyboard? Clicking is faster. ^^

0

You can use mouse to click on Back button in your brouser.

On some mouses you have extra Back key also.

I use Firefox Add-In FireGestures to return back with right click and move left.

0

Ah, you meant that one! I thought you meant the key on the keyboard. :)

Yeah, still another click. So many clicks! Clicks everywhere!

0

I personally prefer using mouse gestures - very simple setup:

Right Mouse Button Down + Up: Refresh browser tab

Right Mouse Button Down + Down: Close browser tab

Right Mouse Button Down + Right: Forward

Right Mouse Button Down + Left: Back

0

I think that would definitly confuse my mouse. It just has two buttons and a wheel. At least it's not mechanical anymore. :D

0

No! The mouse gestures add-on is designed to work with simple mouse without extra buttons!

You just click on right mouse button on any place of the page and without releasing move mouse slightly to the left. You can find the same add-in for other browsers.

0
Show more comments
Moshe Naveh
Jul 10, 2017 at 11:29 AM
0

Hi Steffi,

Sorry for just seeing this now. I will report this bug to IT.

Thank you,

Moshe

Show 8 Share
10 |10000 characters needed characters left characters exceeded
I've unaccepted this answer until the issue is resolved. Otherwise this gets confusing. ;)

.

Regards,

Steffi.

0

Hi Steffi,

I apologize it took me so long to get back to you (vacation time).

I've discussed this with IT and they showed interest in addressing this only if it is proven to be a high priority bug that impacts many users (taking into consideration the other things in our backlog). Would you be ok if we look into once we have more evidences for this impacting many users?

If not, I can share your feedback with IT and think of a different way to move forward.

Regards,

Moshe

0

Just found your reply by accident. You did comment on your answer and not my comment, didn't you. ;)

Well, how can we gather evidance that it's impacting many users? I would think this impacts pretty much everybody who filters for tags that have no content.

It's not a "game breaking bug", yes. So it doesn't need to be fixed right now. I would expect with the new nifty topic pages coming this could be ignored anyway, if the new pages don't inherit this issue. Maybe put it on your test matrix?

.

Regards,

Steffi.

0

:)

We could have some sort of indication by the number of people that complain and our estimation. And I agree with your assumption regarding the topic pages.

0

just to confirm, this bug affects me too.

It is only when filtering questions and answers.

If filtering activities then it works well and keeps the filters on the right (precondition: the activities work)

0

Jürgen, do you still follow some tags you can test this with? Is the issue resolved? Non of my tags have no content.

Regards,

Steffi.

0
Steffi Warnecke

yes this bug is still available, probably there is some demand to keep it ;-)

open our beloved SAP Select tag: https://answers.sap.com/tags/82972118795511538693897596675887

1

Okay, thanks for confirming. So I'll keep the question/bug ticket open.

0