Skip to Content
0

Absence Quotas doesn't get generates based on work schedule rules in QUOMO feature

Jun 24, 2017 at 07:37 AM

79

avatar image

Currently I have a requirement to generate absence quota's based on the work schedule rules through QUOMO feature.
If WSR is General then quota type selection rule group should pick 01 in t599l to generate 30 days annual leave quota base entitlement, and if WSR is SHIFT A then it should pick 02 in T599L to generate 20 days annual leave quota base entitlement based on QUOMO return value. But while executing time evaluation(PT60), the quota type selection rule group always picks 01 in QUOTA node under "Manage time accounts" in time log,Though the employee belongs to SHIFT A WSR maintianed in IT0007. I tried QUOMO feature with EG,EEG,PA & PSA including WSR with appropriate return value. But nothing seems to work

Kindly provide your valuable inputs to resolve at earliest.

please refer to these screenhosts for your reference.




tekil.png (44.5 kB)
kjiwm.png (43.9 kB)
zcnvu.png (43.9 kB)
5nqgn.png (31.2 kB)
npewb.png (36.1 kB)
10 |10000 characters needed characters left characters exceeded

As mentioned by Brendan, please check your PCR that sets your modifiers for Quotas.

To find it, you can use program RPDASC00 to expand your Time Evaluation Schema, checking the boxes to "Expand calculation rules" and "Expand subordinate PC rules", and once you have the report on screen, use the binoculars icon to look for Operation MODIF Q

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Brendan Gibbons Jun 26, 2017 at 03:48 PM
0

Hi,

To troubleshoot this I would set MODIF Q in your version of PCR TMON. This will eliminate QUOMO as a potential source of you issue.

By hardcoding in MODIF Q=01 or Q=02 you should be able to push it to use either rule.

If after doing this it still does not use the expected rule I would review your various ESG / PSG groupings for inconsistencies with your

T559L setup

bg

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Brendan Gibbons,

Thanks a lot. Its working fine now. I just removed the MODIF Q set in 'Determine Groupings ZMON rule. Now the system checks the Quota type selection rule group based on WSR in QUOMO feature.

0
Brendan Gibbons Jun 26, 2017 at 08:53 AM
0

Hi,

Something quick to check.

In the initialisation portion of your schema you will have a PCR for setting groupings.

If you have a MODIF Q=01 in there, that that is likely your problem

bg

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Brendan Gibbons,

Thanks for your reply. I have already checked with MODIF Q in groupings settings. Nothing written on 'Q' anywhere in that PCR.could you please explain me briefly how do we fix this either with PCR or with QUOMO feature? Why this doesn't work if QUOMO structure has work schedule rule provided?

0