Skip to Content
author's profile photo Former Member
Former Member

AS Java applications not starting after patching from 2004s SPS10 to SPS11

Hi folks,

after patching our NetWeaver 2004s from SPS10 to SPS11 and the Kernel from 7.00.83.0 to 7.00.95.0, the applications on the AS Java do not start up automatically any more.

Under the following URLs, the same error is shown:

http://<fully qualified host name>:51000/

http://<fully qualified host name>:51000/nwa

http://<fully qualified host name>:51000/sap/monitoring/SystemInfo

http://<fully qualified host name>:51000/useradmin/

http://<fully qualified host name>:51000/wsnavigator

http://<fully qualified host name>:51000/uddiclient

503   Service Unavailable
SAP J2EE Engine/7.00 
Application stopped.
Details: You have requested an application that is currently stopped

http://<fully qualified host name>:51000/webdynpro/welcome/Welcome.jsp

itself works, the two links Content Administrator and Web Dynpro Console both lead to the same 503 error described above

On http://<fully qualified host name>:51000/irj, the error message is different:

com.sap.engine.services.deploy.container.ApplicationInManualStartUpException:
Application sap.com/com.sap.portal.fpn.accessservice cannot be started because is in MANUAL start-up mode..
Exception id: 09:33_09/05/07_0003_102709250
See the details for the exception ID in the log file

In std_server0.out we have the following entries, right after the list of all services that were started:

ServiceManager started for 39904 ms.

Framework started for 46720 ms.

SAP J2EE Engine Version 7.00   PatchLevel is running!
PatchLevel January 31, 2007 18:37 GMT

May 9, 2007 9:40:19 AM  com.sap.portal.prt.sapj2ee.error [SAPEngine_Application_Thread[impl:3]_3] Fatal:

The last line with com.sap.portal.prt.sapj2ee.error is listed another 131 times, and there is also the following message:

### Excluding compile:  com.sapportals.portal.prt.jndisupport.util.AbstractHierarchicalContext::lookup

We can connect to the system using Visual Administrator. Under Server->Services->Deploy, most applications are not running. It is possible to start a few applications manually, others however do not start showing different exceptions.

We have AS ABAP and AS Java installed, as well as BI, DI, EP and EPC. AS ABAP seems to be running fine.

We have also noticed the following deviations in JSPM:

BC_FES_IGS is Release 7.00 SP Level 7.0

EP_BUILDT is Release 7.00 SP Level 10.0

SAP_BUILDT is Release 7.00 SP Level 0.0

All other components except for the Kernel are Release 7.00 SP Level 11.0 or 11.2

What could be wrong, and what can we do to solve it?

Best regards,

Robert Schulte

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on May 10, 2007 at 05:07 AM

    Hi,

    I can see the exception that startup "mode" is set to MANUAL.

    1.I think,you can go to that particular component in visual admin,and set up the start mode "ALWAYS" instead of "manual".and restart that particular service only.It may help.

    2.If you are using windows,go to services.msc and see if all related services are in "started" state.May be there also,some services are set to "manual"start mode.Bring it to local mode by double clicking on it nad start the services.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 14, 2007 at 02:43 PM

    After rebooting the J2EE server, the components are still enabled in Web Dynpro Content Administrator.

    However, the applications are still not started automatically. We had do it manually using start_app-all via telnet.

    Most error messages / exceptions we get when we try to start applications are based on problems with other components not being running yet, so something seems to be wrong with the order AS Java tries to start the applications in.

    How does AS Java determine which applications it will try to start, and how does it decide in which order they are started?

    Regarding the problem of our empty portal page, we have found the following warning in NWA's Logs and Traces:

    Message: NavigationService.getInitialNodes

    Argument Objects: No Navigation connectors are found,

    Arguments: No Navigation connectors are found,

    Category: /System/Server

    Location: com.sap.portal.navigation.services

    Application: sap.com/irj

    We did not add any custom navigation connectors. Our problem seems to be that the default, role based navigation connector does not work as it should. What can we do to make it work?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Carsten Wilke

      Hi Carsten,

      yes, your post was helpful to us, too. Thanks for that.

      After setting the startup mode for the application you mentioned, the portal came up again. However, many applications for administration purposes still could not be used because they were stopped.

      We found SAP note 946434, which describes a similar problem, but applies only to SPS 7 and 8. The note describes a way to automatically set all applications to startup mode 2.

      We found out that around 160 applications were in startup modes 0 or 1. The startup modes of the applications are listed in /usr/sap/<SID>/<InstanceID>/j2ee/JSPM/tmp/appsnapshot.properties. Obviously, the startup modes were changed somehow when we tried to patch from SPS10 to SPS11.

      Because we are using SPS 12, we decided not to use the tool mentioned in the SAP note to automically set the startup modes. Instead, we manually set the applications to startup mode 2 using offlinecfgeditor.sh, which finally seems to have solved our problem.

      Thanks again to anyone contributing to the solution.

      Best regards,

      Robert Schulte

  • author's profile photo Former Member
    Former Member
    Posted on May 09, 2007 at 11:01 AM

    Hi,

    I can only tell you the possible reasons.

    1.Some services may be stopped or locked.Try restarting the instance and manually start all the services throuch telnet using the

    telnet IP telnet port.

    ex:if IP is 172.16.28.68 and http port is 50000,

    then it will be <b>telnet 172.16.28.68 50008</b> in Command line.

    then enter administrator user credentials.

    then,

    <b>jump 0

    add deploy

    list_app

    start_app-all</b>

    2.Have you applied the right kernel patch.See,if it was a mismatch like,it was unicode version before and u have applied non-unicode now.It could be a possibility.

    3.Check if instance has gone to <b>safemode</b>.

    If it has gone,u should bring it to normal mode through configtool.

    go to /usr/sap/SID/JCxx/j2ee/configtool.

    ./configtool or configtool.bat.

    at the leftcorner,click and select safemode tab and activate option should be <b>NO.</b>

    after doing any changes in configtool,<b>save and restart</b> the instance for the changes to get implemented.

    4.for more specific errors,go through latest <b>default.trace file</b> under /usr/sap/SID/JCxx/j2ee/cluster/server0/log/defaulttrace.trc

    and may be you will get a hint,of what a error is...........

    reward points if helpful...........

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks for your response, usha rani

      1. We already tried that, unfortunately, it does not help

      2. We checked the kernel version thoroughly after you suggested it, everything seems to be fine. We had a Unicode kernel before, and we still have one.

      3. safemode is already set to NO

      4. J2EE's default.trace is full of exceptions, but none of them is pointing me into a helpful direction.

      Perhaps the exceptions mean more to someone else:

      java.lang.Exception: Exception loading and instanciating sub-manager:
      com.sap.caf.km.repositorymanager.CAFSecurityManager
      (java.lang.ClassNotFoundException: com.sap.caf.km.repositorymanager.CAFSecurityManager)
      
      com.sapportals.wcm.repository.runtime.CmConfigurationProvider#
      sap.com/irj#com.sapportals.wcm.repository.runtime.CmConfigurationProvider.Component
      <SetRoomIdForDiscussionObjects> will not be available.
      Failed to load class
      <com.sap.netweaver.coll.room.impl.filter.DiscussionSetRoomIdPropertyFilterManager>
      #J2EE_GUEST#0####1e820b50fe4111db8e780013724175b4#SAPEngine_Application_Thread[impl:3]_22
      ##0#0#Error##Plain###
      java.lang.ClassNotFoundException:
      com.sap.netweaver.coll.room.impl.filter.DiscussionSetRoomIdPropertyFilterManager
      
      com.sap.portal.prt.runtime.broker#sap.com/irj#
      com.sap.portal.prt.runtime.broker#J2EE_GUEST#0####
      1e820b50fe4111db8e780013724175b4#SAPEngine_Application_Thread[impl:3]_22##0#0#
      Error#1#/System/Server#Java###
      [PortalServiceItem.startServices] service initialisation failed:
      tc.eu.odi.conn.uwl|OdiBridgeService
      [EXCEPTION]
       {0}#1#com.sapportals.portal.prt.core.broker.PortalServiceInstantiationException:
      Could not instantiate implementation class com.sap.tc.eu.odi.conn.uwl.OdiBridgeService
      of Portal Service tc.eu.odi.conn.uwl|OdiBridgeService because: could not load the service
      
      com.sap.engine.services.deploy.container.ApplicationInManualStartUpException:
      Application sap.com/com.sap.portal.fpn.accessservice cannot be started
      because is in MANUAL start-up mode.
      

      There are many more entries in default.trace.

  • author's profile photo Former Member
    Former Member
    Posted on May 10, 2007 at 05:33 AM

    Hi,

    Here "http://<fully qualified host name>:51000", Is it 51000 or 50100..

    Regards

    Umesh K

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 11, 2007 at 01:46 PM

    It looks like our problems were initially based on wrong kernel files.

    We are running a Unicode kernel on Linux IA32 with MaxDB. Until yesterday, there was no database specific kernel patch available for us. The corresponding entry was greyed out.

    So we ended up with a kernel consisting of new DB independent files and old DB dependent files.

    After going back to the previous kernel, we still had to start all applications manually (using both the telnet method described above and the Deploy service in Visual Administrator). Then we had to enable all components in Web Dynpro Content Administrator. Somehow they were automatically deactivated when we patched the system.

    All web-based admin tools are running now. However, the portal page http://<fully qualified host name>:51000/irj only shows the header (with Welcome, Search, the SAP Logo, the History Link etc.), but the main part of the screen is blank.

    @Umesh: Our instance number is 10, so the corresponding port number is 51000.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.