/scripts/ahub.form.attachments.js
2

Bug: "Key" property gets lost when editing class in eclipse

Jun 26, 2017 at 09:13 AM

132

avatar image

When a class implements interface IF_WORKFLOW, an additional "Key" property column appears in the SE24 editor's Attributes tab. However this setting gets cleared for all attributes whenever the class's public section gets changed using Eclipse.

I've never encountered this in a long time of using eclipse so am 90% convinced this used to work OK. Currently seeing this on the latest ADT with both and 7.4 SP11 and 7.5 SP2

If anyone from SAP reads this and can confirm it is a bug: Please let me know if it's more convenient to report this via OSS and I can open a message.

10 |10000 characters needed characters left characters exceeded

Hi Mike,

it will helpful if you mentioned the ADT version too.

BR, Suhas

0

Sorry was too lazy to look it up and just wrote "latest" as I'd checked for updates this morning. It's 2.77.1.

0

Forwarded url to ADT

2
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Uwe Fetzer Jun 26, 2017 at 11:12 AM
4

Hi Mike,

this problem is solved with Note 2400131.

Cheers, Uwe

Show 11 Share
10 |10000 characters needed characters left characters exceeded

Hi Uwe,

Normally someone from the ADT Dev Team posts the release notes for the new releases, but i couldn't find one for 2.77.

Are you aware of any such release notes?

BR, Suhas

1

Yes, please! I just spent the last half hour unsuccessfully trying to find the release notes.

1

Hi Raghu,

ADT Release Notes are called "What's New" and can be found at

1) Help Portal - Note that the URL contains a NW release number that you might have to adjust for later versions
2) Within ADT itself: choose menu Help -> Help Contents -> open the relevant guide in the tree (e.g. ABAP Development User Guide) -> What's New ...

There is one What's New section per development guide. Besides these there are usually blogs by Thomas Fiedler or Wolfgang Woehrle, so you could additionally follow them on SCN.

Best regards,
Armin

2

Sweet! Thank you!

0

Hi Suhas,

please see the answer for Raghu regarding release notes.

Best regards,
Armin

0

Thanks Armin for the link...

I see that with the 2.77 version you have added the "Run as ATC with..." Option ... Big Thanks for that :)

0

This was not directly an ADT problem. The problem also occured with the Source Code Based Editor in SAP GUI.

The note solved the problem in both development envionments.

0

Thanks Uwe. We have a system upgrade pending so can't apply the note at this time, but I will take it on good faith it solves the issue.

0

Hi Mike,

the problem with the disappearing flag is solved, believe me ;)

One problem is still there and will probably never be solved: in the source you cannot see, that the flag is set and you cannot set the flag itself in the code. You still have to go to the formular based editor once after you inserted the interface IF_WORKFLOW.

Maybe the kernel team will add a pseudo command for this in the future ...

Uwe

0

Yes this has never been a code-level feature, I would have thought it would be relatively simple to add a keyword that maps to the table field that the setting represents.

But as setting the flag is a one-off (when it works properly), I can live with it. In most cases it's pretty obvious what the key is and there are more important features and bugs to deal with. Exception classes and persistent classes are also not quite eclipse-ready, but I don't hold out much hope for persistent classes.

0

Just to follow up: we upgraded to 7.5 SP6 and the bug was still there. Applied note and it's fixed. The note is valid from 7.5 SP7

1
Skip to Content