Skip to Content

HANA Express: HDB daemon not running

Hello,

I ran HANA Express 2.0 (2.00.000.00.1479874437) already for a longer time and did quite some work (configuration, development, demos, ...) in it. Now as I wanted to start it last time, I always get the message "FAIL: process hdbdaemon HDB Daemon not running" when launching "HDB start". Actually I did not need to do this earlier, the HANA DB started itself after launching the VM.

What to do? I do not want to re-install HANA Express, because there is already lot of work in it, I urgently need it for customer demos - and unfortunately the last VM snap shot happend also months ago.

Thanks,

Ingo

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jul 07, 2017 at 08:14 AM

    I found the solution: From whatever reason the file "[...]/global/hdb/custom/config/nameserver.ini" was empty with change date exactly the day when this behavior first happend. Note 2080933 explains how to resolve the problem.

    I found the line "nameserver: [landscape]/master is missing in nameserver.ini. did someone delete SYS/global/hdb/custom/config/nameserver.ini ?" in daemon_hxehost.39000.000.trc.

    As a further step I had to delete all files in /usr/sap/HXE/HDB90/hxehost/lock.

    Regards, Ingo

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 27, 2017 at 04:48 PM

    Ingo - I recently saw a similar issue - but it turned out to be related to the tenant db not being able to start because Smart Data Streaming (SDS) was configured for an old IP address (which due to a network re-work, ended up changing). Are you running SDS? Is your tenant db not starting? Did your IP address recently change? If so, it may be as simple as changing the SDS configuration file to ensure it points to the proper IP address. If you're not running SDS (or a tenant DB), then try doing an HDB stop, re-boot the machine, then a re-start - and see if that helps.

    Regards, Mike

    Add comment
    10|10000 characters needed characters exceeded