Skip to Content
avatar image
Former Member

S4 Hana - Not able to determine automatic credit check for sales order

Dear All,

I have configured credit management functionality under FSCM in S4 Hana. I have maintained in tcode UKM_BP – Credit profile tab, the Rules, Risk class, Customer group and checking rule.
I have also maintained business role UKM000 and maintained the Credit segment and credit limit and Credit Control Area for Business Partner.
However not able to determine auto credit check in sales order. Kindly guide me how can i determine credit check in sales order.

I followed the following steps for configuring credit management:-

SPRO > Financial Supply chain management > Credit Management > Integration with Sales & Distribution:-
1) Define Credit Segment
2) Assign Credit Control Area and Credit Segment
3) Assign Sales Area to CCA
4) Determine Active Receivable per Item category
5) Define Credit Groups
6) Assign Sales Document & Delivery Document
7) Define Risk Category
8) Define Auto Credit Check (Credit Update - 000012) (Sap Crdit Management (Ticked) Reaction (D) Status /Blocked(Ticked).
9) Customer Enhancement, Activated BADI (Connection of SD to SAP Credit Management)
10) In Transaction (UKM_BP) - In General Data ...credit profile Tab:-
Maintained: - Rules , Check Rule , Customer Group.

In Credit segment data...Credit Limit and Control Tab.
Maintained - Credit Limit,

11) In Sales & Distribution Tab..maintained Credit control area.

Kindly suggest if at all any further config is required, since credit check not getting activated in sales order.

Thanks & Regards.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jul 04, 2017 at 06:53 AM

    Hi Keshav,

    Have you made sure that all the relevant caches have been cleared before testing? Especially if you have been changing configurations in the backend you should run transaction /IWBEP/CACHE_CLEANUP and clear the OData model cache to pick up your configuration changes.

    There are similar caches in the Fiori Frontend Server - e.g. /IWFND/CACHE_CLEANUP & /UI2/INVAL_CACHES and of course clear your web browser cache as well.

    If it's not caching then you'll need to give some more detail - and preferably some screenshots showing us what you are expecting to see and where you are expecting to see it.

    Rgds,

    Jocelyn

    Add comment
    10|10000 characters needed characters exceeded