Skip to Content
0
Former Member
Apr 24, 2007 at 09:09 AM

Can't add comments ... part of greater KM problem I think

48 Views

Hi there

I can't add comments to my web templates. The error I get when trying to add a new comment is:

Cannot get properties for assignment
Cannot get the folder for assignment
Error while launching new document dialog

Further playing around has led me to try and create new documents in the <b>Documents on InfoProvider Data</b> folder under <b>BI Repository</b>, and there too I get an error, which says

Cannot read content from IContent instance. Error: You are not authorized to create a document with these properties 

I then tried adding a document from transaction RSA1, and there too I got an error, similar to the above, this time saying

You are not authorized to create a document with these properties

I have looked around on SDN, and one of the discussions referred to note 947209, but that is not applicable as we already have that patch applied. One of the other discussions speaks about ensuring that all 0CTA* objects must be activated, and in particular 0TCAIPROV, but these are already activated.

My portal user is assigned to super_admin, so I don't believe it could be those permissions that are missing.

I have an entry in table RSPOR_T_PORTAL, with the following values:

KM MetaData Repository = /bw_metadata

BI CM Repository Prefix for MetaData = <empty>

BI CM Repository Prefix for MasterData = <empty>

BI CM Repository Prefix for InfoProvider Data = <empty> or /BI_Repository (both have been tried and still get errors, was empty to start with)

Please, any advice to sort this out would be most appreciated.

Cheers,

Andrew