Skip to Content

does RTCCT has to generate records with group values?

Jun 20, 2017 at 05:39 AM


avatar image

hi gurus:

I m working in S4H 1610 FPS01 with RTC, my question is when I run the Currency translation using t-code RTCCT specifying the Top Group node of my ownership hierarchy I see that this program creates data in ACDOCC table but in the group field all the records have G_NONE, is this correct? I am expecting to have all these records with Group=GR_ABC (which is the ID of my top node) because that is the value I m indicating and those records will be needed later for running the eliminations in BPC Web.

This is how I run RTCCT:

and this is the result in ACDOCC:


rtcct-group.jpg (81.0 kB)
acdocc-table.jpg (199.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Lucas Gabriel Jun 20, 2017 at 08:20 AM

Hi Joseph,

From what I understood last time spoke to SAP S/4 RTC CT (At this release) will always post to G_NONE.

That option to enter the group in BPC, will only be used to select Entities and Currencies in BPC.

Need to be careful with that option, because another thing it will do is to translate everything to all currencies assigned to the groups below the entered group, which in my opinion, it can be a problem. e.g.: if you have 20 groups being 19 USD and only 1 EUR at very end of the ownership structure - the method will translate everything to USD and EUR, even the entities that has nothing to do with he EUR group.

To move from G_NONE to group level - you need to create an Integration business rule. You can find some information in this link:



10 |10000 characters needed characters left characters exceeded
Joseph Angulo Jun 21, 2017 at 09:14 PM

Hi Lucas:

Thanks, so now I understand that RTCCT it does not generates data with group assigned, just with G_NONE, I was taking a look about the article you shared so this is what I did:

1. Integration mode activated

2. multiplier created

3. elimination rule created

4. run consolidation

so looks lilke everything is fine but I run the consolidation , no data is generated in ACDOCC for this, I have tested this using the BRule for account transformation and it works fine, but when I try to use this BR automatic adjustment,no data is generated.

what could be wrong?

10 |10000 characters needed characters left characters exceeded
Lucas Gabriel Jun 21, 2017 at 10:40 PM

1 - Ok

2- Why duplicated lines?

3- Adjustment Type must be type I = Integration.

- No source or destination Audit Trail

10 |10000 characters needed characters left characters exceeded
Joseph Angulo Jun 21, 2017 at 11:24 PM

Hi Lucas, I have already did these couple of changes, but still no data created...I m not sure if it is because my source data in ACDOCC, which is this:

As you can see all the data is balanced to zero, maybe that is the reason? How is your data when you worked in this?

data-acdoca.jpg (83.2 kB)
Show 5 Share
10 |10000 characters needed characters left characters exceeded

Balance zero wouldn't be the problem, in theory the balance will be zero for all entities in G_NONE.

Can you please share if there is any error message and also your ownership structure?


Hi Lucas, this is my ownership hierarchy:

Some questions:

1. Do you think this is because I don't have anything in: Consolidation PCT-Generated / Control PCT-Generated / Consolidation OWN-Generated ?

2. the consolidation monitor doesnt throw any error messages, no dumps in ST22, no error logs in SLG1

3. is this the right way to customize BPC Consolidation in this version? I mean: RTCCT for Currency Translation and Integration Rule to assign group values to data in group currency
I have experience in BPC Standard and I never saw the need to use this Integration Rule


Seems ok to me. The lack of the generated won't affect your consolidation.

The integration was created for cases where CT is not ran in BPC - for example CT in ECC. It it works just fine.

Make sure you're following the settings in this note:

1665088 - Integration mode in consolidation


Hi Lucas, it is strange, I have set up every step of this sap note but nothing is generated when I execute the consolidation monitor.

Just to be sure, my understanding is that in your RTC demo you are following these steps:


2. Integration Rule

3. Elimination Rules

is that right?


Yes, the sequence is right.

It is really strange indeed, and the problem is that most of the times is something small that went unnoticed.

What I do recommend is to go through each characteristic:

- Flow - Make sure you have at least one opening and closing flow type

- Audit Trails, Entities and Group - double check the consolidation characteristics.

Last case scenario debug class CL_UJP_CONSOLIDATION

Joseph Angulo Jul 05, 2017 at 11:21 PM

I have found the solution, it was in the multiplier:

I only need 1 row for both methods in the Entity method column.

Thanks for your help and time Lucas.


multiplier.jpg (44.7 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded

And I asked about the duplicated lines on the 21st June...

Good news that is sorted now. Cheers


Dear both,

I have the same setting, still it doesn't work, seems like the issue is :

multiplier should only point to Group Formula = 1. 100,101 99 0 1 0

In the Integration rule the Group Formula Account should be equal = to source account.

Joseph Angulo Jan 08 at 10:38 PM

Hi guys, this is the official answer from sap:

2577390 - Result values are not generated for consolation groups after running RTCCT


10 |10000 characters needed characters left characters exceeded