Skip to Content
author's profile photo Former Member
Former Member

Error while loading the Web template "0ANALYSIS_PATTERN" (return value "4")

Hi,

I configured Web BEx and complete to do check Iist in "Diagnostics &Support Desktop Tool" all status was green. But I find a error when open BEx Web Analyzer

error message :

"

Error while loading the Web template "0ANALYSIS_PATTERN" (return value "4")

ERROR: Command type SWITCH_AXES of object not recognized

ERROR: Parameter GENERAL_TEXT_ELEMENT not recognized; check your metadata

"

So i run RS_TEMPLATE_MAINTAIN_70 (0ANALYSIS_PATTERN(A)) report to check and choose validate.

error message :

"

Command type SWITCH_AXES of object not recognized

Command type SWITCH_AXES of object not recognized

Command type SWITCH_AXES of object not recognized

Parameter GENERAL_TEXT_ELEMENT not recognized; check your metadata

Query 0D_DX_M01_Q0006 does not exist in the BI System (Object QU 0D_DX_M01_Q0006)

Cannot instantiate data provider

"

This system was installed with Java add-in installation.

Abap and Java SPS level 12

Any idea to solve that ?

Thank in advance

Korkiat.S

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    Posted on Apr 24, 2007 at 07:37 AM

    Hi,

    You definitely have to activate 0ANALYSIS_PATTERN newly. These errors are simple inconsistencies in the 0ANALYSIS_PATTERN on your system in comparison to your metadata.

    E.g. command SWITCH_AXES was changed to SWAP_AXES. You are getting the error that SWITCH axes does not exist -> meaning that your 0ANALYSIS_PATTERN is old.

    Simply check the difference between "A" and "D" version in RS_TEMPLATE_MAINTAIN_70. I will expect that "D" version is than correct (you can copy the "D" version to another template and execute it for check)

    Regards, Karol Kalisz

    SAP NetWeaver BI Development

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Kalisz,

      After I update SP SEM-BW lv 13 to fix short dump

      and run RSA1 to install BTMP (0*).

      Now this problem was solved.

      Last question, Why did it happen?

      The QAS system hasnot error like this.

      Thank you all of you for support,

      Korkiat.S

  • author's profile photo Former Member
    Former Member
    Posted on Apr 23, 2007 at 08:49 AM

    more information :

    I already try to re-actiavte the template 0ANALYSIS_PATTERN from RSA1

    but this error still occur.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 23, 2007 at 08:59 AM

    Hi,

    Go to transaction SPRO -> SAP NetWeaver -> SAP Business Information Warehouse -> Settings for Reporting and Analysis -> BEx Web -> Set Standard Web Templates -> execute...

    After that restart your J2ee engine.

    see note 990321

    if it is useful assign points.

    Regards,

    Senthil Kumar.P

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Kumar,

      It don't work. BEx Web Analyzer still error with the same message.

      The first time BEx Broadcaster can open but now it don't work too.

      Please confirm my step

      I fill all field in 'Set Standard Web Templates' with 0ANALYSIS_PATTERN

      then open RSA1 > BI Content > Object Types

      I select some object following note. 990321 and transfer to the right side frame.

      then choose dropdown 'install' > install

      Restart SAP

      Open portal > BEx >> it still error

      Regard,

      Korkiat.S

  • author's profile photo Former Member
    Former Member
    Posted on Apr 23, 2007 at 08:59 AM

    sorry, currently Abap and Java SPS was 11.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 19, 2011 at 02:51 PM

    Hi,

    i faced the same error and solved it just by transporting 0ANALYSIS_PATTERN and its components form test to prod (it worked on testsystem.

    0D_DX_M01_Q0006 seems to be a query from the business demo content. I am not sure about, what this query has to do with this error ...

    Regards, Bert

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.