Skip to Content
0

PGP Decryption

Jun 19, 2017 at 10:16 AM

35

avatar image
Former Member

Hi all,

I am doing a decryption scenario. Generated public and private key using GPG. I could decrypt the file using 3rd party tool. Hence, keys are working fine.

However, when implemented in PI (by giving the modules a) ownPrivateKey and b) pwdOwnPrivateKey in the sender communication channel) I am getting the error : org.bouncycastle.openpgp.PGPException: error setting asymmetric cipher


The only solution for this issue I could find was deploying unlimited strength JCE policy files. I downloaded the file for JRE1.8 (we run on JRE1.8) However, I am still facing the same issue.

Another SAP note 1915999 suggested the JCE files might not be properly installed and suggested to verify at http://<host>:<port>/BC//VerifyJCE. However, this link is not accessible (corresponding URL in my system: http://ntsapqx2-ap1:50100/BC//VerifyJCE).

1. Can anyone suggest where I might have gone wrong?

2. Is there another URL where I can verify that the unlimited JCE file is correctly installed?

Any suggestions will be highly appreciated. Thanks!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

avatar image
Former Member Nov 08, 2017 at 09:10 AM
0

Hello,

The url has and extra slash , the good one is http://<server>:<port>/BC/VerifyJCE

Share
10 |10000 characters needed characters left characters exceeded