Skip to Content

Minisap dont show ALV

Hi abapers,

I am using the minisap 4.6 version, to study. I like to see the data from a table (spfli, saplane or any other, in the "contents" button) but i cant do it.

I tried to create an alv grid with function and with O.O but they didnt display me the data. Then, I tried this code:

http://www.erpgenie.com/abap/controls/alvgrid.htm

and nothing happens again... Can someone tell me what i doing wrong? Or my old minisap is the problem...

Thanks in advance.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Apr 24, 2007 at 01:20 AM

    Hi Rodrigo,

    Sometimes, it can also be due to code problems. Two checks you need to do here.... First check is to find out if data is available in the internal table passed to the Method <b>SET_TABLE_FOR_FIRST_DISPLAY</b>...Second check is to verify whether the screen details in screen painter has been activated or not..To check that , double click on the screen number in the statement

    CALL SCREEN 100.

    You will be directed to the screen painter. Just check if the screen is activated.Sometimes, it can happen like that....If not active, activate it and execute the program again...

    Hope this will help you..

    Regards,

    SP.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 18, 2007 at 08:08 PM

    Hi,

    have you checked if there is anything inside this tables. Use either transaction SE16 or SE16N.

    Regards,

    Wojciech

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 18, 2007 at 08:09 PM

    Hi,

    Please check the SAPGUI. To me it sounds more like an SAP GUI installation or version issue than an SAP Server.

    Also check if the tables you are using has any data.

    No data...no grid.

    Regards,

    Sumant.

    Add a comment
    10|10000 characters needed characters exceeded

    • Helo guys,

      the table has data, because i executed the program SAPBC_TOOLS_GENERATOR_NEW that generate data to many tables.

      with the list view code, i can see the data. But i want to study alv...

      se16 display the msg error: "No changes on SAP objects allowed"

      regards

      Message was edited by:

      Rodrigo Paisante

  • Posted on Apr 24, 2007 at 04:38 PM

    Ok, thanks to all!

    But i re-install the frontend, and it works.

    But this version, 4.6, has a lot of bugs.

    I removed this version and i installed the 6.1 version.

    Now... all alv displays correctly, and i can see all table contents.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.