Skip to Content
avatar image
Former Member

B2B process failing iDoc for PO isnt working, error message No 06030

Hi all,

First i´d like to explain some of the process, we create an RFQ and send it via iDoc to the vendor 6000006 that is a partner (external system), with this system the RFQ is sent to the vendors and the real vendor to wich the PO will be created is selected, then the external system then sends back an iDoc that triggers a PO creation referencing the RFQ number but with the new vendor as reciever, i have all the iDoc scheme customized for 600006 vendor in the WE20 for the outbound parameters, the message type REQOTE with type base ORDERS05 for the RFQ is correctly sending the iDoc, then for the ibound parameters i have the message type PORDCR1 with type base BAPI that uses the BAPI_PO_CREATE1 in the background, but the PO isnt creating because of the message No 06030 ""Reference vendor 6000006 differs from vendor 6000007" i know the vendors differs because i want to create a PO for the real vendor to wich i will buy the materials, and the RFQ is created for the external system (vendor 6000006), i am a functional consultor and want to make it as standard as posible, and i need all the process working with iDocs and automatic sending and PO creating referencing the RFQ data, is there a standar way to do it? what can i do? i already have all the EDIs configured and they are working good the only problem is that error message is not allowing the PO to be created. but i need to reference the RFQ when the automatic PO is created for the process to work for the client...can anyone help me? what can i do for it to work?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jun 16, 2017 at 10:57 AM

    does it work when you do it manually?

    How is the message customized, warning or error? Does it work if you make it hidden?

    Add comment
    10|10000 characters needed characters exceeded