Skip to Content
avatar image
Former Member

Problem with SOAP receiver adapter

hello, I have the next escenary IDOC -> XI -> SOAP.

I send one IDOC to XI, XI receiver the idoc and send to XX by message SOAP. I mark the flag "Do Not Use SOAP Envelope" in receiver adapter SOAP.

If I send the message without User Authentication the message arrived OK but when I put User Authentication with User and Password I have the next message:

XIAdapter/HTTP/ADAPTER.HTTP_EXCEPTION-HTTP 400 Bad Request.

Somebody knows what happend?.

Thanks for all.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Apr 16, 2007 at 11:37 AM

    Hi,

    1. When you select DO Not Use SOAP Envelope in the reciever SOAP adapter, you have to create the entire SOAP Envelope in your mapping. Have you done this?

    2.><i> If I send the message without User Authentication the message arrived OK but when I put User Authentication with User and Password I have the next message:</i>

    Doesnt this imply that the Webservice does not need any authorization?

    Regards

    Bhavesh

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi -

      >>>How I can develop the enveloped SOAP in my mapping

      The SOAP envelope basically looks like this:

      <SOAP-ENV:Envelope
        xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
        SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
         <SOAP-ENV:Body>
             <m:SomeMessage xmlns:m="Some-URI">
                 <messagePart>test</messagePart>
             </m:SomeMessage>
         </SOAP-ENV:Body>
      </SOAP-ENV:Envelope>

      By default, only the SOAP Body is the "payload". When you use the option "Do Not Use SOAP Envelope", the entire SOAP envelope has to be constructed via a mapping, for example.

      Do you have to use the SOAP envelope option? Does your web service require the use of custom SOAP headers? Otherwise, you shouldn't need this option.

      Regards,

      Jin