Skip to Content

Process Flow control is not working on different language setting

Hi Everyone!

I have a process flow controller which is working fine in default URL (without any language is mentioned) or mentioned as EN

?sap-client=001&sap-ui-language=EN#/PROCESSFLOW/1

whenever i change language parameter to any other language, process flow control is not appearing, (but my JSON data is bound to the model)

What can be the problem ?

here is my index.html;

<script src="https://sapui5.hana.ondemand.com/resources/sap-ui-cachebuster/sap-ui-core.js" 
id="sap-ui-bootstrap"
data-sap-ui-language="en"
data-sap-ui-preload="async"
data-sap-ui-compatVersion="edge"
data-sap-ui-libs="sap.m,sap.suite.ui.commons"
data-sap-ui-theme="sap_bluecrystal"
data-sap-ui-appCacheBuster="./"
data-sap-ui-xx-bindingSyntax="complex"></script>

in chrome i can see sometimes library-preload error is occurring. Thanks a lot!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jul 19, 2017 at 08:32 AM

    ok found the problem already :) my bad.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 09 at 01:44 AM

    Vitor Mendonça Santos Silva

    Hi Dos Santos,
    Process flow is a very sensitive control. Any attibute you are sending leading it not to generate at all. I would suggest it to generate with a dummy json first. Just make sure your nodes and lanes are properly maintained. Lanes should start from 0

    Add comment
    10|10000 characters needed characters exceeded