Skip to Content
avatar image
Former Member

Applying a model using SAP PA Model manager with selected fields

Hi All,

Im facing some issue in Applying a model using SAP PA model manager where the scheduled task(Apply a model) output its always the KXINDEX (internal SAP PA numbers).
Can i change that to some key field from my input datasets for e.g, Customer ID?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Jun 15, 2017 at 06:07 AM

    Hi Eric, when you create your model, at that step where you have the list of fields, you need to set the Key property to the value "1" in case of your customer ID field. This should do the trick.

    I am confused about your mention of Model Manager. Are you referring to our SAP Predictive Analytics 2.x component? Are you aware that in 3.x release, this has been replaced by the Predictive Factory, our strategic investment for all-things predictive moving forward?
    Let me know how this goes,
    Kind regards
    Antoine

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Antoine,

      What if the model is already built without the key Value set as "1"? do we have an option change that on the existing model?

      Im using the SAP Predictive Analytics 2.2.0. im aware of the newer version 3.x, but this is what we currently have.

      Thanks!

  • Jun 15, 2017 at 07:15 AM

    Hi Eric,

    In fact, you have to re-generate the model.

    Kind regards Antoine

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 14, 2017 at 12:51 PM

    Hi, where are you bulding your model? In Automated Analytics or Predictive Factory? Kind regards, Antoine

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      To Add on, the model was buildt on a datasets from a database (table) and im trying to apply the model on newer dataset Database table as well using SAP model manager task.

  • Jun 15, 2017 at 07:15 AM

    Hi Eric,

    In fact, you have to re-generate the model.

    Kind regards Antoine

    Add comment
    10|10000 characters needed characters exceeded