Skip to Content
author's profile photo Former Member
Former Member

ALV Export to Bex Analyzer

Hi All.

I saw that in the ALV export button, there is an option to export to Bex Analyzer. But it does not work. Clicking on it gives a dump.

What is it for? How to make it work?

Also, how do I disable that option?

Thanks in adv.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Apr 12, 2007 at 03:46 AM

    Hi Sharma,

    For me also its giving Dump. Actually if Bex Analyser is not there in your system then it will open the same data in Excel itself. But it is giving the dump. I don;t know what is the reason for that.

    To disable the Export option you need to set the following property. But there is no option to disable only the Bex Analyser from Export Button.

    <b>Code is:</b>

    wd_comp_controller->r_table->if_salv_wd_std_functions~set_export_allowed( ABAP_FALSE ).

    Warm Regards,

    Vijay

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 21, 2007 at 05:21 PM

    Any clue on this one? We also want to just disable the Bex Analyzer option.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 30, 2008 at 10:30 AM

    hi all,

    i am facing the same problem.

    i want to hide the BEX analyzer option but excel option needs to be shown.

    can anyone suggest some solution for the same.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 31, 2008 at 11:53 AM

    Hello All,

    The Bex Analyzer and Web Analyzer was not so stable so now it has been removed from NW SP13 onwards. May be in future you get a stable Bex Analyzer in SAP ALV.

    I hope that answers your question.

    Thanks & Regards,

    Amol

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.