Skip to Content
0

Connect design studio (from my laptop) to SAP ESP (on the sever)

Jun 14, 2017 at 04:12 AM

214

avatar image
Former Member

Hello Everyone,

I am using design studio 1.6 with SAP ESP 5.1 SP11. When I am trying to connect to ESP project it works fine if I use design studio install on the same machine as SAP ESP. but When I am trying to using Design studio on my laptop to connect to project in my server it doesn't work

I have configured everything correctly. Like adding boe directory in ESP. wsp.bat file is always running. I am confident that I have configured this right cos locally I can connect design studio to vmap project.

Facing the issue only when using design studio installed on my laptop. Can anyone please tell me how should i troubleshoot or resolve this issue?

Thanks

Happy

10 |10000 characters needed characters left characters exceeded

You will need to provide a lot more detail in order for anyone to offer meaningful input. Tammy's question about a firewall is a good one. If you can provide the connection details you are using in both the successful connection between Design Studio and ESP on the same machine and the unsuccessful connection between Design Studio and ESP on separate machines it will help. Any error messages you are receiving would also be useful.

1
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
avatar image
Former Member Jul 21, 2017 at 06:29 AM
0

Hi Robert,

Thanks a lot for the help through out. I can now confirm that the issue is resolved. I had to remove <allowOrigin>*</allowOrigin> from wsp.xml file.

I used design studio installed on the server and that connected just fine to my native server view esps://ESP51.demo.local:19011. then I removed allow origin line from wsp.xml just to try, restarted wsp.bat and can successfully connect design studio from laptop to ESP model.

Thanks yo so very much to help me with this and supporting me with patience for all of my questions. I am facing other issues but for that I will create another discussion.

Thanks Happy.

Share
10 |10000 characters needed characters left characters exceeded
Tammy Powlas
Jun 14, 2017 at 09:20 AM
0

Could this be a firewall issue between your server and laptop? Is there a way for your network administrator to check this?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jun 16, 2017 at 03:24 AM
0

Thanks Tammy for getting back to me. on wsp.bat cmd screen i see request coming in. more over I have turned of all the firewalls as this is sandbox environment.

the properties I am using are as bellow.

This works fine when I use design on the same server. but I am not sure if I am suppose to use same properties when I connect design studio outside of the server.

Thanks a lot again in advance.

Happy


capture.png (10.2 kB)
Show 13 Share
10 |10000 characters needed characters left characters exceeded

You still haven't given us any information on the error you are receiving. You should be getting some error message when you click the "Connect" button in Design Studio and it fails to connect.

You also haven't provided any info on possible firewall or network routing issues. For example, can you simply ping the 10.48.57.185 IP address from the machine you are trying to connect Design Studio from?

0
Former Member

Hi Robert Thanks for getting back and apologies for not being specific.

When I click on the connect button and the hover over to red cross it says network error. But when I ping I get successful results and more over I have run telnet command for port 9091 as well and it shows port is open. As I mentioned earlier I have turned off firewalls settings and I am sure firewalls are not blocking the request.

I am not sure if this will help. These are the steps I have followed

1.In Cmd window Executed C:\Sybase\ESP-5_1\cluster\config\esp1 start_db.bat

2.In Cmd window Executed C:\Sybase\ESP-5_1\cluster\config\esp1 start_node.bat node1 (windows stays open as I think if I close I will kill node1 running)

3.In cmd Executed C:\Sybase\ESP-5_1\wsp wsp.bat (windows stays open as I think if I close I will kill wsp running)

4.Open the ESP studio and imported vmap project

5.Made changes to vmap.ccr

a.Added local cluster in project configuration

b.Set “wen service enable” to true

6.Vmap is successfully running on local cluster (esp://localhpst:9786)

I have attached all the screenshot. Let me know if you need more.

Thanks for your help again.

Happy

cluster.png (40.4 kB)
cluster.png (40.4 kB)
node.png (8.4 kB)
wsp.png (25.8 kB)
0

Can you show the Run-Test perspective with the vwap project running? From the screenshots you posted above, it looks like you are probably running it on the default cluster (localhost:9786) started by Studio as opposed to starting it on the configured cluster on port 19011.

1
Former Member
Robert Waywell

Hi Robert,

you are correct, I wasrunning the project on default cluster. When i am trying to configure new cluster on port 19011 it is give me error while starting it. I have attached screenshots. should I be performing other steps before i try to connect it to server?

Steps I have performed are

  1. in SAP ESP run-test I created new server URL
  2. right click and connect server, it prompts me for password.
  3. then I get error.

Thanks a lot again for your help with this. you have been such a great help

19011.png (11.0 kB)
error.png (11.1 kB)
0

With ESP on Windows you are using Windows authentication by default when working with a full cluster. This contrasts to the local cluster started by ESP Studio.

What user ID did you try to log into the ESP cluster with?

Had you granted that user any permissions on ESP using the streamingclusteradmin tool?

1
Former Member

Hi Robert,

I am using SYS_STREAMING user for this and yes I have granted permission using bellow command line.

streamingclusteradmin --uri=esps://10.0.0.185:19011 --username=SYS_STREAMING --password=Password1

I have attached screenshot for the command I have run to grant the permission.

perm.png (13.2 kB)
0

The SYS_STREAMING user is an admin user only - you can use this user to grant permissions to other users. As I mentioned, ESP authenticates the user via the native Windows authentication. In order to connect to the ESP cluster for the purpose of running projects, you need to use a valid Windows domain user ID who has also been granted permissions on ESP.

For example if your Windows domain login was "singhh@my.corp" then you would use the SYS_STREAMING user to grant permissions to "singhh" and then use "singhh" to log in to the ESP cluster to deploy and run the project.

1
Former Member

Hi Robert,

that makes sense. I have now given rights to my windows user and tried to login to cockpit with that user and that works. bellow are the rights I have given.

  1. grant perm view on all to user <user>
  2. grant perm admin on all to user <user>
  3. grant perm write on all to user <user>
  4. grant perm read on all to user <user>
  5. grant perm start on all to user <user>
  6. grant perm stop on all to user <user>
  7. grant perm add on all to user <user>
  8. grant perm remove on all to user <user>
  9. grant perm admin on system cockpit to user <user>
  10. grant perm all on system cockpit to user <user>

after that SAP ESP run test and clicked on add new server. in the host name i gave ip address and port 19011 with protocol as Web services and clicked saved. then right click and connect server which prompted me for user id password.

I entered above windows user id and password. but it still gives me bellow error.

I am not sure I am still missing anything. my wsp.bat, node1 and db is running. where are the logs saved?

Note:- After trying above things I went to cockpit via browser and manually uploaded my project I am working on. First I created workspace and then uploaded project files. I started the project and then input_adopter. I am just playing with this not sure if this right way of doing this or not. after this as well I am not able to connect design studio though.

Thanks hips. you have been such a great help.

Happy

0

What happens if you connect from Studio using the Native protocol?

The WSP should be writing output to the command line where you started it.

Check the wsp.xml and verify that the Hostname and Port parameters are correct for your cluster. For debugging purposes, I would also suggest setting the allowOrigin parameter to '*' to ensure that requests from any source are being permitted.

0
Former Member

Hi Robert,

I have tried with native protocol and I can start the cluster and load the project.

Can I please ask what the difference is between these two?

I made the changes in setting the allowOrigin parameter to '*' and hosted the project in native protocol with ssl successfully. Then I tried to connect from design studio but still no luck. As you suggested now I can see in wsp screen some logs when design studio tries to connect. I am attaching that for the reference.

one more thing i tried is used the Advanced REST client extension as suggested in this article

https://archive.sap.com/discussions/thread/3714119

very interesting results when I tried to access my project. here are the screenshots.

when i use http link

when i use https

if I am not wrong this is suggesting me something is not right in wsp.xml file.

here is my wsp.xml file. One thing I know is 5th line in the file. which is <protocol>http</protocol> when I am creating native cluster I have to check SSL in order to get that working. same with in order to get logs to be written in wsp screen in design studio connection i have to tick the ssl check box.

i am not sure in wsp.xml file weather it should be https or http. I have implemented out of the box ESP. i dont have any certificate for SSL

<?xml version="1.0"?>
-<webService enabled="true">
<soapPort>9090</soapPort>
<restPort>9091</restPort>
<protocol>http</protocol>
<tls>TLSv1.2</tls>
-<webSocket enabled="true">
<webSocketPort>9092</webSocketPort>
<!-- use SSL ? -->
<secured>false</secured>
<tls>TLSv1.2</tls>
<!-- Max number of publish connections a single web socket instance will serve This effectively specifies how many remote connections will publish data over a single connection to Streaming -->
<publishSocketLoading>5</publishSocketLoading>
<!-- Max number of subscribe connections a single web socket instance will serve This effectively specifies how many remote connections will be served by a single connection from Streaming -->
<subscribeSocketLoading>5</subscribeSocketLoading>
<dropSlowSubcribers>false</dropSlowSubcribers>
</webSocket>
<maxFormContentSize comment="bytes">200000</maxFormContentSize>
<cacheSize>10</cacheSize>
<!-- Set log4j trace level for WSP: TRACE|DEBUG|INFO|WARN -->
<trace>INFO</trace>
<!-- Use to change the configuration of the thread pool used by Jetty. WSP uses the QueuedThreadPool class, which is Jetty's default. -->
-<threadPool>
<!-- Minimum number of threads to spawn -->
<minThreads>20</minThreads>
<!-- Maximum number of threads that Jetty may spawn to serve incoming connections -->
<maxThreads>500</maxThreads>
<!-- Time in milliseconds a thread needs to idle before it becomes eligible to be stopped -->
<idleTimeout>30000</idleTimeout>
</threadPool>
<!-- Restrict the response header of Access-Control-Allow-Origin for REST APIs 0 or 1 entry of origin should be provided here (no entry means *) eg. <allowOrigin>http://localhost:9091</allowOrigin> -->
<allowOrigin>*</allowOrigin>
-<DefaultCluster>
<Hostname>esp51.demo.local</Hostname>
<Port>9786</Port>
<Workspace>default</Workspace>
<Authtype>user</Authtype>
<SslEnabled>true</SslEnabled>
<!-- Max number of socket connections (publish or subscribe) to Streaming to create per project instance -->
<projectLoading>50</projectLoading>
</DefaultCluster>
<!-- This section is not processed if the 'enable' attribute is set to false. Advanced options to tune how WSP publishes data to Streaming. WSP is configured to provide best performance and scalability by default. Please refer to the documentation for a description of how each option may impact WSP and different values interact. To modify these options - change the 'enable' flag to true below. -->
-<publishOptions enabled="false">
<!-- Specifies publish blocking mode. Allowed values are 'none', 'explicit', 'auto' -->
<publishBlockMode>none</publishBlockMode>
<!-- Setting to a positive value enables buffered publishing. Rows are buffered internally and sent to Streaming in the background. This is the default operating mode. -->
<publishBufferSize>4096</publishBufferSize>
<!-- Only applies if using explicit blocking mode -->
<publishBlockSize>256</publishBlockSize>
<!-- If set to true, WSP will use transaction blocks instead of envelopes. This applies only if blocksize is set -->
<publishUseTransactions>false</publishUseTransactions>
</publishOptions>
<!-- This section is not processed if the enable attribute is set to false. Allows tuning of Streaming subscription connections from WSP. -->
-<subscribeOptions enabled="false">
<!-- How long will Streaming wait for a subscriber to read all base data. Note if there are multiple client connections sharing a subscription to Streaming, all of them will be dropped if a slow client is encountered. -->
<baseDrainTimeout/>
<!-- Should Streaming drop a subscriber that is slow in reading data? Note if there are multiple client connections sharing a subscription to Streaming, all of them will be dropped if a slow client is encountered. -->
<dropable/>
<!-- The internal subscription queue size Streaming should create. Larger values allow more rows to be buffered internally. Helps with slower clients but increases memory requirements -->
<queueSize/>
</subscribeOptions>
-<Security>
-<Keystore>
<Type>JKS</Type>
<File>keystore_rsa.jks</File>
<Password encrypted="true"> WnDBGqhGowp6dydQiGbe+Ohr9/QPsjOim6hGMQQhcGxoIxIe </Password>
</Keystore>
-<Cipher>
<File>wsp.key</File>
</Cipher>
</Security>
</webService>
wsp-log.png (27.8 kB)
http.png (20.9 kB)
1.png (38.8 kB)
0

The 404 error is a good indication that you do not have the WSP running. The fact that you can connect to the ESP cluster using the Native protocol confirms that your ESP cluster is running.

If you don't have an SSL certificate configured then in your wsp.xml file you should have:

<SslEnabled>true</SslEnabled> 

changed to "false".

You then need to be consistent in using HTTP for your connections and not HTTPS.

Is the wsp.xml file that you posted above for your system? If so, then you have not configured the host name and port of the ESP cluster:

<Hostname>esp51.demo.local</Hostname>
<Port>9786</Port>

The host name should be the fully qualified domain name of the machine where the ESP cluster is running. Based on previous discussion I believe you have your ESP cluster configured to run on port 19011.

0
Former Member

Hi Robert,

I made the changes you suggested above and managed to get more errors in my wsp screen.

I followed this article where you have helped for configuring wsp.xml

https://archive.sap.com/discussions/thread/3789310

Here is the snapshot of my run perspective. I have two questions.

  1. on native protocol I can only run project when I tick ssl without that I cant manage to get that working.
  2. so my project is running in studio on esps://esp51.demo.local:19011 i cant manager to get that working on esp://esp51.demo.local:19011 or http://esp51.demo.local:19011 or http://esp51.demo.local:19011

here is my wsp.bat running

now I am trying to connect design studio to the project which gives me an error:invalid connection detail.

my wsp screen give me the error as well when design studio makes the request.

any more suggestions?

thanks

run.png (8.0 kB)
wsp.png (22.8 kB)
ds.png (13.3 kB)
wsp-error.png (54.0 kB)
0

The good news is that the output is showing that WSP is starting and that the request from Design Studio is reaching the WSP. I believe the next issue is that the ESP cluster is expecting a secured connection ("esps"), whereas we had turned that off by changing the SslEnabled setting to "false".

Since your ESP cluster is using SSL, can you try changing SslEnabled back to true?

<SslEnabled>true</SslEnabled> 

That parameter should be controlling the connection between the WSP and the ESP cluster.

In contrast, the:

<protocol>http</protocol>

and

<!-- use SSL ? -->
<secured>false</secured>

parameters should be controlling whether the WSP is expecting HTTP versus HTTPS traffic from outside connections.

Don't change those settings or the connection values in Design Studio for the moment as that portion of the connection appears to be working with the current settings.

0