Skip to Content
0

How do i deactivate high cardinality on infoObject

Jun 13, 2017 at 10:09 PM

198

avatar image
Former Member

I am getting an error message that an infoObject has high cardinality in BW. How can i deactivate it.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Bhavin Vyas Jun 14, 2017 at 08:49 AM
0

At which place you are getting this error in BW. What is the exact error.

In case you are having issue with date fields in Cube for High carnality than see this one,

https://archive.sap.com/discussions/thread/3574917

Hope it helps!

Thanks,

Bhavin Vyas

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

It has noting to do with InfoCube. The message is saying there is a high cardinality set of the infoObject. I have been working with this tool for eons and never seen high cardinality set on an infoObject.

I am able to add the infoObjects 0ASSET & 0ASSET_MAIN in the DSO and infoCube, but cannot add it to a multiProvider.

Message:

Only permitted InfoObjects (not contained InfoObjects) transferred

Message No. R7I316

Diagnosis

You are trying to add a set of InfoObjects to a dimension.

System Response

Some of the InfoObjects could not be added to the dimension. This might occur in one of the following cases:

  • Adding a high cardinality InfoObject. High cardinality InfoObjects cannot be used in InfoCubes, since SIDs are required when querying InfoCube data. As high cardinality InfoObjects do not have SIDs, you cannot use this InfoObject type in InfoCubes.
  • Adding a stock coverage key figure to to DataStore object: Stock coverage key figures are not supported by regular DataStore objects.

Procedure

If this InfoObject is really required in the InfoCube, go to the Remodeling Toolbox workbench (transaction RMSRT) and convert the InfoObject.

NOTE: The Remodeling does not work!

Got the same message on an Amount Key Figure yesterday with Aggregation set to no aggregation (Somethign i've done umpteen times before). Could not add the Key Figuge to an infocube. It was seeing the Keyfige as a STOCK COVERAGE KEY FIGURE Type instead of an AMOUNT Key Figure type

0
Former Member

I also note SAP left these infoObjects out of the infoCubes they delivered in Business Content.

All I need to find is where they set this high cardinality flag on the infoObject. They state that this is needed when more then 2 billion records exist. Why do they think a client would have over 2 billion Assets?

0
Yugandher yadav Jun 19, 2017 at 12:19 PM
0

Hi .

High cardinality option is related to Indexing. Not sure what your exact issue is about Cardinality on Infoobject?

But technically we can go to the particular dimension and Uncheck the ‘High cardinality Option’ to deactivate it.

Thanks

Yogi

Share
10 |10000 characters needed characters left characters exceeded
Loed Despuig Jun 27, 2017 at 07:38 AM
0

Hi,

High cardinality is being assigned in the dimension of an infocube. Check your cube which dimension was configured with high cardinality.

Regards,

Loed

Share
10 |10000 characters needed characters left characters exceeded