Skip to Content
0

No items found in dependent code list with context mapping.

Jun 13, 2017 at 06:43 AM

42

avatar image

Hi,

recently I face a problem to create a custom context dependent codelist of elements which depends on standard codelist BusinessObjectTypeCode. I have done context codelist mapping for dependent codelist but no item found in dependent code list when independent list item selected.

I attached a file with details description below;

Could you please help me why no item found in dependent codelist. Is there any query required to populated dependent list?

Thanks and Regards

Swati

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Andres Gutierrez Jun 13, 2017 at 07:54 AM
0

Swati,

I faced this issue before and I believe is due the fact that the QC view is not correctly generated.

To solve this, please perform following actions:

  1. Please delete "BOCode" and "BOElement" from your view model
  2. Add 2 new structures to you list "TargetFields" Bind 1 structure to your to BO-Model attribute BOCode. Same action for BOElements. After the binding is performed, you wil have in your struture a attribute callen content which point to the value of you BO-Model.
  3. Perform once more the Model Codelist Context Mapping of content.
  4. Dont forget to add your new fields on the View Designer.

Have a look to an example on my screenshot below.

Let me know whether this approach solve your issue.

kind regards,

Andres


untitled.png (208.2 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Andres,

Thanks for help.

I have performed all your steps, but this approach does not solve my issue.

Will you please give me some other way to solve the QC view generation problem?

The present data model is given below;

Thanks,

SWATI

0

Hi Andres,

My issue has been solved. You are right that the QC view is not correctly generated. It takes long time to populate the codelist.

I solved it like that, I removed context mapping and activate QC. Then run from browser normally all Elements populated.

Then I did context mapping ans activate QC again. Then it runs properly according to BO.

Thanks again.

Swati

0