Skip to Content
0

Unable to connect using HTTPS With Client Authentication SOAP Sender

Jun 11, 2017 at 05:40 PM

108

avatar image

Hello Experts,

I had created SOAP sender channel HTTPS With Client Authentication and trying to connect with SOAP UI and also tried to dummy soap receiver channel. I'm pasting traces from XPI

I had added certificate to user

Key store

Scenario works fine with http but im facing problem with https.

Please help me with the issue.

Regards,

Rajesh

xpi1.jpg (156.4 kB)
xpi2.jpg (262.1 kB)
xpi3.jpg (300.7 kB)
xpi4.jpg (243.4 kB)
xpi5.jpg (254.6 kB)
userinfo.png (66.8 kB)
keystore.png (117.8 kB)
10 |10000 characters needed characters left characters exceeded
Former Member

Thank you Manoj

0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Rajesh Marupaka Jun 12, 2017 at 03:19 PM
0

Hi Gurus,

Any help really appreciated.

Regards,

Rajesh

Share
10 |10000 characters needed characters left characters exceeded
Manoj K Jun 12, 2017 at 06:26 AM
0

Rajesh,

1.In the log it shows "Certificate not provided by callback" . So can you please make sure if the correct private key is assigned to your request in SOAP UI ? if possible please provide the screenshot of SOAP UI with Private key.

2.Is SSL configuration done for your PI system ? NWA-->Config-->Infra-->SSL.

3.Is the certifiacte which you are using are self signed or CA signed ? I tried in the past with self signed but had this same issue , i got the CA signed certificate working in 7.4 single.

Br,

Manoj

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Manoj,

Please find the attached private key.

2. Please find the attached SSL configurations

Its self-signed certificate i'm using.

Regards,

Rajesh

privatekey.png (107.7 kB)
ssl.png (104.2 kB)
0

Rajesh,

By looking at the screenshot it looks like you are using the default ssl certificates which were present in ICM_SSL_<ID>..Isn't it ? If yes then i don't think you can use those cert , check if you have can get a CA signed certificate and test it accordingly .

As mentioned above i never got this success with self signed certificate , i recently tried the same but however when tested with CA signed i got this working , with the same settings.

Br,

Manoj

0

Hi Manoj,

I had downloaded certificate from ICM_SSL_XXXXX clicked on Generate CSR Request and got that certificate self signed and imported CSR Response into the same view.

and i had also stored same certificate into TrustedCAs. Is it correct way?

Why it won't work with self signed if 3rd Party accepts it and stores it in TrustedCA of there browser?

Regards,

Rajesh

keystore.png (101.7 kB)
0
avatar image
Former Member Jun 19, 2017 at 10:51 AM
0

Hi Manoj,

Yes, you are correct. It was only working with TrustedCA not with selfsigned Certificate.

Thank you very much,

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Good to Hear Rajesh . Can you please close this thread.

And also if possible try to dig it if its possible with self signed , even i am working on the same . And update the same here so that it would be helpful for others.

0