Skip to Content
1

Develop Multi-Target Applications in Eclipse/HANA Studio

Jun 11, 2017 at 11:11 AM

295

avatar image

Dear,

Is there a document to illustrate how to develop MTA in Eclipse? Or SAP doesn't support this officially? I saw the official document "Developer_Guide_for_SAP_HANA_XS_Advanced_Model" just describes the Web IDE approach. But I really don't like the Web IDE.

Best regards,
Thanks,

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Steven CHEN Jun 17, 2017 at 03:40 AM
1

Hi Michal,

I understand. But I got some annoyed error when editing the procedure in Web IDE of HANA Express. Currently the Web IDE is not matured enough to completely dispense the Eclipse.

This is my view...

Best regards,
Thanks,

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Perhaps you can give Web IDE Multi-cloud a try and see how it goes. Much room for improvement there as well but in the coming release it will hold both DB and Java modules in addition to the existing HTML5 module.

Regards,
Michal.

0
Nachshon Vagmayster
Jun 28, 2017 at 09:01 AM
-2

Hi Steven

While Web IDE provides set of tools to support MTA development, such development can also be achieved with other editors. Off-course without the MTA specific tools this task will be more complex.

The following chapter in the XSA developer guide describe the development process without Web IDE, hope this helps

Best Regards,

Nachshon

Share
10 |10000 characters needed characters left characters exceeded
Michal Keidar
Jun 14, 2017 at 09:54 AM
0

Hi Steven,

May I ask what don't you like in Web IDE? We always try to improve..

We have the new Multi-cloud version released in which you can develop MTA applications:
https://blogs.sap.com/2017/05/11/announcing-general-availability-of-sap-web-ide-multicloud-version/

Thanks,
Michal.

Show 11 Share
10 |10000 characters needed characters left characters exceeded

Hi Michal,

I agree that the Web IDE multi-cloud version is certainly a good editor to kick start the application development for SCP and tremendous efforts are being put forward to support its continuous evolution, but it appears that it currently supports or contains templates only for a HTML5 module.

Does it support or contain templates for developing a node.js, DB or a Java (or a Spring application) module ?

Thanks,
Sagar J

0

Hi,

Thank you for your feedback!

DB and Java modules will be available in our upcoming release which is in the coming days :)

Give it a try.

Regards,
Michal.

0

Is there any tentative date by which the support for these modules would be available in WebIDE.

Thanks,

Sagar J.

0

I cannot commit on dates here. But soon.

0

These are good news, what about support for Java code completion and check in upcoming release? This feature is another great lack of functionality in my humble opinion. Without code completion / suggestion / check one would be forced to import source code from git just to compile and deploy it....

0

Java code completion is currently in process, cannot say when it will be provided but it's definitely in our plans.

0

Hi Michal,

Some others also have the same problem. I was a Java developer before SAP. I know you have put lots of efforts to the Web IDE project. But could I say it's the tech that is too premature to support the heavy enterprise level platform like HANA? It's unfriendly, very slow, sometime annoyed error popup just drives me crazy.

I don't think this could attract more and more developers to SAP/HANA community.

Sorry for the complaining.

0

Thank you for your feedback, it's very important for us.
We are constantly working on improving the experience in Web IDE and we're aware that we still have a lot of work to do.
if by chance you get to work on Web IDE again and get the annoying popup, perhaps you could attach a screenshot of it here. Maybe we could at least get rid of it.

Thanks,
Michal.

0

Hi Michal,

The annoyed popping is

'n.getCurrentSchema is not a function'. Please see the attachment...

annoyed-popup.png (342.8 kB)
0

Hi Michal,

Multi-cloud version can be used in the HANA Express?

Thanks,
Steven,

0

Hi Steven,

These are two different products. Although some features from Web IDE for HANA are included in Web IDE Multi-cloud, and more will be included in the future.

0