/scripts/ahub.form.attachments.js
0

Hybris Marketing - Loading the metadata for service 'CUAN_CAMPAIGN_SRV' failed.

Jun 13, 2017 at 09:49 AM

357

avatar image

Dear Experts,

after upgrading our Hybris Marketing System to release 1702 we have problems with the new app "Campaigns".

When klicking on it the following error appears: Sorry, a technical error occurred. Please try again later.

Error Details are:

{
	"requestUri": "/sap/opu/odata/sap/CUAN_CAMPAIGN_SRV/$metadata?sap-client=100",
	"statusCode": 500,
	"statusText": "Internal Server Error",
	"headers": [],
	"body": "<?xml version=\"1.0\" encoding=\"utf-8\"?><error xmlns=\"http://schemas.microsoft.com/ado/2007/08/dataservices/metadata\"><code>/IWBEP/CM_MGW_RT/100</code><message xml:lang=\"en\">Property (external name) 'A2HFB4T8BLO4276115I2LJPRWJZI' not found for entity 'CUAN_CAMPAIGN_METRICS_Q001Result'.</message><innererror><application><component_id>CEC-MKT-ANA-COM</component_id><service_namespace>/SAP/</service_namespace><service_id>CUAN_CAMPAIGN_SRV</service_id><service_version>0001</service_version></application><transactionid>58014E01AEDF0090E00593A77EF9F781</transactionid><timestamp>20170613094449.2854370</timestamp><Error_Resolution><SAP_Transaction>Run transaction /IWFND/ERROR_LOG on SAP Gateway hub system (System Alias LOCAL_CEI) and search for entries with the timestamp above for more details</SAP_Transaction><SAP_Note>See SAP Note 1797736 for error analysis (https://service.sap.com/sap/support/notes/1797736)</SAP_Note></Error_Resolution><errordetails/></innererror></error>"
}

In transaction /IWFND/MAINT_SERVICE when trying to load metatata for service CUAN_CAMPAIGN_SRV the error is:

Loading the metadata for service 'CUAN_CAMPAIGN_SRV' failed. Check the error log.

In details it says here in the error log:

Property (external name) 'A2HFB4T8BLO4276115I2LJPRWJZI' not found for entity 'CUAN_CAMPAIGN_METRICS_Q001Result'.

What could be the problem here?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Joyca Vervinckt Nov 09, 2017 at 01:33 PM
0

Hello Oliver,

We are facing the exact same issue.

How did you solve it?

Thanks,

Joyca

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Dear Joyca,

we had issue with misisng target mappings if I remember well. Please check following screenshot.

solution-sap.png (119.2 kB)
1

Thanks Oliver for your answer.

On both my DEV and QAS there are also only 13 target mappings in my SAP_CEC_BC_MKT_CPM1_OP catalog and on DEV it does work, on QAS not. Were there any other actions on your ticket that were handled earlier? Would you mind sharing your ticket number, I also have a ticket open at SAP for this and I could reference yours so SAP can internally check what they did on your ticket exactly?

I want to try adding e.g. Member mapping but I don't have a system to base my entries on; e.g. what to add in the URL field...

Kr,

Joyca

0
Former Member

Hi Joyca,

I'm now facing the exact same issue.

How did you solve it?

Also, can you share the OSS?

/Kim

0

Hi,

The SAP Support ticket is still open;

On the Quality system it was solved; but on our Production system the exact same issue appears again.

On Quality; we followed SAP Note 2473352 and it's prerequisite note.

In the prerequisite Note you need to add an RFC connection to the DEV system in transaction SEGW on the CUAN_CAMPAIGN_METRICS service; and in note 2473352 you execute transaction BSANLY_BI_ACTIVATION for bundle CUAN_BI_CONTENT but there you need to use the RFC connection to the QAS system itself (this is not very clear in the note, hence I mention it).

So on QAS that worked for us but on PRD we still face the error, despite having done all the same steps that did fix it on QAS...

Hope this info is of help to you,

Kind regards

Joyca

0
Skip to Content