Skip to Content

GuildFTP : File-To-File Adapter Scenario

Hello Friends,

I am using GuildFTP installed on my Laptop and configured File-To-File Scenario in SAP XI.

I have configured communication channels for sender and receiver. For this purpose we have created two folders one for upload and other for download purpose.

In my sender communication channel we have option to delete file after successful file transmission. This is happening as expected. File is getting deleted in GuildFTP folder (local system folder file).

Now the issue is same file is configured in mapping which must be saved in download folder. For this purpose I am using FTP connection to GuildFTP pointing to download folder.

Which is not happening.

Is there any settings I must make in SAP XI / GuildFTPd?.

Your valuable inputs in this regard will be highly appreciated.

Best Regards,

Krishna

HP

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Apr 09, 2007 at 08:16 AM

    Hi Nagendra Krishna,

    This is seen with most of the SAP XI developers.

    You can try out following.

    1. Check the user credentilas for the destination folder (Target folder ) of GuildFTP.(Do you have set the maximum authorizations i.e. "read / write"),if not then please make the necessary change.

    2.Also chek in your receiver communication channel for

    2.1 User details

    2.2 Target destination details (i.e. please check whether this address in the receiver channel points to your destination folder ) if not then please do the needful.

    If you are still facing the problem then please feel free to ask me through sdn or through my mail mentioned in my profile.

    Kindly reward the points if you find this reply a helpful one.

    Regards,

    Vishal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Is it working now?

      One more format.

      Recordset Name : EMP

      Recordset Structure : CONTACTS,*

      CONTACTS.fieldNames : NAME,ADD,MOBILE

      CONTACTS.fieldSeparator : ,

      CONTACTS.endSeparator : 'nl'

      It should work fine now.

      Regards

      Sundari

      Reward points for helpful answer

  • avatar image
    Former Member
    Apr 05, 2007 at 08:55 AM

    Check SXMB_MONI for any errors in Integration engine and also check the status of communication channel in communication channel monitoring in RWB.

    Regards,

    Jai Shankar

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Nagendra Krisha

      Hi Nagendra,

      Try checking communication channel monitoring from RWB->Component Monitoring->Adapter Engine->Communication Channel Monitoring. Here you can get insight what is going wrong with your communication channel by selecting appropriate filter criteria. Generally the issues with FTP configurations are regarding permission. Check whether you have permission to write in the destination (download) folder.

      Regrads,

      Amitabha

  • avatar image
    Former Member
    Apr 09, 2007 at 11:14 AM

    Hi Nagendra,

    I am absolutely agree with Jai,that the problem seems to be in receiver.

    Can you please check again the address of the target folder u have set in the receiver communication channel.

    Regards,

    Vishal

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 10, 2007 at 08:26 AM

    Hello,

    When I change my Message Protocol settings to "File Content Conversion" and perform FTP. I dont find my scenario not working.

    Scenario is only working when Message Protocol set to "File".

    Is there any wrong doing stopping my message in reaching destination folder?.

    I am bit confused with File Content Conversion, Can anyone please give me step by step appraoch to solve this issue.

    Best REgards,

    Nagendra Krishna

    Add comment
    10|10000 characters needed characters exceeded

    • Hello All,

      My problem got solved, the issue was that mapping was not done correctly.

      I take this opportunity to below mentioned consultants to Thank them for valuable inputs/help in solving my issue.

      Jai Shankar

      Amitabha

      Vishal

      Satish

      Sundari David

      You guys are too good.. Many thanks for your suggestion and help.

      Best Regards,

      Nagendra Krishna

      nagendra.krishna@hp.com

  • Apr 12, 2007 at 04:05 AM

    Many thanks for all you helped in solving the issue.

    Add comment
    10|10000 characters needed characters exceeded