Skip to Content
0

Not able to open annotation file in annotation modeler from SAP Web ID

Jun 12, 2017 at 11:09 AM

362

avatar image
Former Member

I am trying to create an App from a Smart Template and Annotation File. I have created a project (Project from templatate -> List Report Application -> with ES4 backend -> service GWSAMPLE_BASIC -> added annotation file).

Once project created, I am trying to open the annotation file, Open With -> Annotation Modeler, but it is giving below error message.

OData metadata cannot be loaded from destination ES4. This error can appear for several reasons:

  • The login data is incorrect: provide the correct credentials.
  • The OData Service URI is missing or defined incorrectly. Please check the OData Service URI in the manifest.json file (app descriptor) of this project.
  • The connection to the backend is not available. Please check the destination in the neo-app.json file of the project and make sure that the backend system is available

Kimdly help me to resolve this issue.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Michael Roger Oct 18, 2017 at 04:55 AM
2

if you didn't find it, i think i did...

the problem seems to be that the web IDE does not read the property "settings.localUri" of the service...

if you just have uploaded a local metadata-file you have to set

"mainService": {"uri": "localService/metadata.xml","type": "OData","settings": {"annotations": ["localAnnotations"],"localUri": "localService/metadata.xml"}
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Jul 11, 2017 at 11:45 AM
0

Hi Div,

Could you please check your manifest.json -> datasources: It should look similar like the following.

"mainService": {
"uri": "/sap/opu/odata/iwbep/GWSAMPLE_BASIC/",
"type": "OData",
"settings": {
"annotations": [
"localAnnotations"
],
"localUri": "localService/metadata.xml"
}
},
"localAnnotations": {
"uri": "annotations/annotations.xml",
"type": "ODataAnnotation",
"settings": {
"localUri": "annotations/annotations.xml"
}
}

Share
10 |10000 characters needed characters left characters exceeded
Malcolm Clark Dec 05, 2017 at 02:09 PM
0

I had the same issue so made the change as Michael suggested and this worked for me. The modeller now works. Thanks Michael.

Problem is, that has stopped the app itself from running, so I have to revert back to the old uri to get it to work. Then change it again if I want the modeller to work!

This is nuts to say the least! Any ideas how to get around this?

thanks, Malcolm.

Share
10 |10000 characters needed characters left characters exceeded
Malcolm Clark Dec 05, 2017 at 03:30 PM
0

ok so I think I understand this a little better now. I changed it in the ‘manifest.json’ to say localService – so that just means I am now COMPLETELY defining the annotations locally and it now ignores all of the annotations I had in my CDS view. So to get it to work I have to either use this new modeller and define all of my annotations from scratch (as there are none at all in the modeller for this) or else, just do as I was doing before and have it look at the annotations in my CDS View.

So, the Modeller is pretty pointless…..unless I can find a way of getting the annotations from my CDS come into my local copy. Any thoughts/ideas?

thanks.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Malcom,

Updating the URI in manifest.json to use the local copy of the metadata is not intended for the productive usage.

Do you also use the GWSAMPLE_BASIC service? In any case, please contact me and we will look into your particular case and help you to resolve the issue.

Best Regards,

Mariana

0

You can contact me via email, or create a ticket on the component CA-WDE-PI-AM

Thanks

Mariana

0