Skip to Content
avatar image
Former Member

server0 never comes up J2EE down- Urgent!!!!!

Hi,

Ihave installed a SM 4.0 system with ABAP+Java.

After all done with SP10, I had changed the master client from 001 to 100 which I created. From then my Server0 is not starting at all.

I tried all the below:

1. Created a new client 120, did a client copy with SAP_ALL of 000 client and users of 001 client.

2. CHanged the productive cleint in configtool to 120 and gave SAPJSF as the ume.r3.connection.master.user

3. I changed my data source to datasource_abap.xml from the portal data source. (I was not able to follow note 718383, as my server0 was already down.

Now I still get UME error and the server0 does not start at all.

In between, I enabled the superadmin user SAP* and the server0 came up, but all my SLD, Useradmin pages were balnk and had no data at all.

Now I get errors which are below: Please help, as I did all that I could. May be still I miss something.

My hostname is also correct, but the log says MSGHOST, MSSERv is wrong.

Not sure where is the mistake.

security.0.log

#1.5#000C29F94F1B001E00000006000010FC00042D46241F5B62#1175679183796#/System/Security/Usermanagement##com.sap.security.core.persistence#######SAPEngine_System_Thread[impl:5]_53##0#0#Fatal#1#com.sap.security.core.persistence#Java#Initialization of UME persistence adapter "" failed.##Initialization of UME persistence adapter "" failed.#1#R3_DATASOURCE#

#1.5#000C29F94F1B001E00000009000010FC00042D46241F6332#1175679183796#/System/Security/Usermanagement##com.sap.security.core.server.ume.service.UMEServiceFrame#######SAPEngine_System_Thread[impl:5]_53##0#0#Error#1#com.sap.security.core.server.ume.service.UMEServiceFrame#Plain###UME initialization failed.#

#1.5#000C29F94F1B001E000000000000127000042D4630837790#1175679391718#/System/Security/Usermanagement##com.sap.security.core.persistence#######SAPEngine_System_Thread[impl:5]_70##0#0#Fatal#1#com.sap.security.core.persistence#Java#User Management Engine (com.sap.security.core.persistence.datasource.imp.R3Persistence) failed to connect to the ABAP backend system. Check that connection data are correct and the backend system is available. Error message: "". Connection data (obtained from properties of UME service in section "ume.r3.connection.master.": "".##User Management Engine (com.sap.security.core.persistence.datasource.imp.R3Persistence) failed to connect to the ABAP backend system. Check that connection data are correct and the backend system is available. Error message: "". Connection data (obtained from properties of UME service in section "ume.r3.connection.master.": "".#2#Connect to message server host failed

Connect_PM TYPE=B MSHOST=rockcrystal GROUP=PUBLIC R3NAME=SM4 MSSERV=rockcrystal PCS=1

ERROR service 'rockcrystal' unknown

TIME Wed Apr 04 18:36:31 2007

RELEASE 700

COMPONENT NI (network interface)

VERSION 38

RC -3

MODULE ninti.c

LINE 530

DETAIL NiPGetServByName2: service 'rockcrystal' not found

SYSTEM CALL getservbyname_r

COUNTER 1

#{

passwd=********

receiverid=master

sysnr=01

client=120

poolmaxsize=10

mshost=rockcrystal

user=SAPJSF

gwserv=sapgw01

r3name=SM4

msserv=rockcrystal

receiverid_guest=master

ashost=rockcrystal

}

#

#1.5#000C29F94F1B001E000000020000127000042D4630838782#1175679391718#/System/Security/Usermanagement##com.sap.security.core.persistence.datasource.imp.R3PersistenceBase.init()#######SAPEngine_System_Thread[impl:5]_70##0#0#Error#1#com.sap.security.core.persistence.datasource.imp.R3PersistenceBase#Java#An exception was thrown in the UME/ABAP user management connector. Message: .##An exception was thrown in the UME/ABAP user management connector. Message: .#1#Connect to message server host failed

Connect_PM TYPE=B MSHOST=rockcrystal GROUP=PUBLIC R3NAME=SM4 MSSERV=rockcrystal PCS=1

ERROR service 'rockcrystal' unknown

TIME Wed Apr 04 18:36:31 2007

RELEASE 700

COMPONENT NI (network interface)

VERSION 38

RC -3

MODULE ninti.c

LINE 530

DETAIL NiPGetServByName2: service 'rockcrystal' not found

SYSTEM CALL getservbyname_r

COUNTER 1

#

#1.5#000C29F94F1B001E000000040000127000042D4630839041#1175679391718#/System/Security/Usermanagement##com.sap.security.core.persistence#######SAPEngine_System_Thread[impl:5]_70##0#0#Error#1#com.sap.security.core.persistence#Java#User Management Engine (com.sap.security.core.persistence.datasource.imp.R3Persistence) failed to initialize the ABAP data source: ##User Management Engine (com.sap.security.core.persistence.datasource.imp.R3Persistence) failed to initialize the ABAP data source: #1#Connect to message server host failed

Connect_PM TYPE=B MSHOST=rockcrystal GROUP=PUBLIC R3NAME=SM4 MSSERV=rockcrystal PCS=1

ERROR service 'rockcrystal' unknown

TIME Wed Apr 04 18:36:31 2007

RELEASE 700

COMPONENT NI (network interface)

VERSION 38

RC -3

MODULE ninti.c

LINE 530

DETAIL NiPGetServByName2: service 'rockcrystal' not found

SYSTEM CALL getservbyname_r

COUNTER 1

#

#1.5#000C29F94F1B001E000000060000127000042D4630839B1C#1175679391734#/System/Security/Usermanagement##com.sap.security.core.persistence#######SAPEngine_System_Thread[impl:5]_70##0#0#Fatal#1#com.sap.security.core.persistence#Java#Initialization of UME persistence adapter "" failed.##Initialization of UME persistence adapter "" failed.#1#R3_DATASOURCE#

#1.5#000C29F94F1B001E000000090000127000042D463083A2E8#1175679391734#/System/Security/Usermanagement##com.sap.security.core.server.ume.service.UMEServiceFrame#######SAPEngine_System_Thread[impl:5]_70##0#0#Error#1#com.sap.security.core.server.ume.service.UMEServiceFrame#Plain###UME initialization failed.#

I followed the Note to change productive client also. Still same issue.

Regards,

KP

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Apr 04, 2007 at 10:19 AM

    could you please check the ERROR service 'rockcrystal' unknown

    UME problem mean there is mismatch with your password which you have given in configtool and the password in ABAP. try to sync the password in abap/configtool

    Cheers,

    -Sunil

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Markus Doehr

      Hi Markus,

      I had changed the settings in config tool and configured the datasource.abap.xml properly with all the required ume.r3.connection paramteres.

      Nowe everything is fine except only one error. I get an error on the anonymous user.

      The security.0.log file gives the below error.

      "Anonymous principal not configured"

      #1.5#000C29F94F1B001E000000030000125400042D421AD2D242#1175661847906#/System/Security/UserStoreUME##com.sap.security.core.server.userstore.UserContextUME#######SAPEngine_System_Thread[impl:5]_16##0#0#Error#1#/System/Security/UserStoreUME#Java###Error while trying to get the anonymous user: #1#Cannot find first configured anonymous user: J2EE_GUEST: USER_AUTH_FAILED: User account for logonid "J2EE_GUEST" not found!#

      #1.5#000C29F94F1B001E000000050000125400042D421AD2F1E8#1175661847906#/System/Security##com.sap.engine.services.userstore.UserContext.(UserContextSpi, Properties)#######SAPEngine_System_Thread[impl:5]_16##0#0#Fatal#1#com.sap.engine.services.userstore#Plain###Can not instantiate UserContext with given properties.#

      So I enabled the superadmin user and password in config tool to SAP* and now the server0 starts. But the issue is, now if I go to the useradminscreen, it is blank. I am not sure what is to be done.

      How do I proceed further in this? Do I have to make any changes in Visual administrator, so that I can correct the UME in-consistencies.??? Why is my browser blank???

      Please do help...

      This is my useradmin URL that is showing in the browser address bar:

      http://172.27.1.2:50100/webdynpro/dispatcher/sap.com/tcsecumewdumeadmin/UmeAdminApp

      Only my J2EE index.html page has a proper URL. All other pages like, SLD, UME, etc has tcsecumewd kind of URL. Not sure if this would be an issue.

      I tried to follow the below SAP help, but I do not find those parameter anonymous user ID in the UME properties.

      2.1. Activate SAP* (“emergency user”)

      Change the UME properties:

      ○ ume.superadmin.activated=true

      ○ ume.superadmin.password=

      Restart the server.

      Log on to the UME Web application (/useradmin), where you can search for users and groups. You can also create missing users and groups or fix the mapping between them.

      If you even see an error like Anonymous principal not found or Anonymous principal not configured, the guest user may have been deleted. In addition to the properties mentioned above, you have to change the guest/anonymous user settings:

      ○ UMEproperty:

      ume.login.guest_user.uniqueids=SAP*

      ○ J2EE Engine Security:

      In the Config Tool, switch to configuration editor mode and choose Security ® Userstores ® UME User Store. Set anonymous-user=SAP.*

      ○ J2EE Engine Security:

      In the Config Tool, switch to configuration editor mode and choose Security ® Userstores ® UME User Store ® Configuration. Set anonymous-user=SAP.*

      When you have finished, change these settings back again and restart the server.

      Regards,

      PK

  • avatar image
    Former Member
    Apr 05, 2007 at 11:37 AM

    Hi,

    regarding new client on Solution Manager:

    as client 001 has special customizings for Service Desk Issues of Solman, you should have to make a client copy with SAP_ALL from client 001, but not 000 !

    Cinar

    Add comment
    10|10000 characters needed characters exceeded