Skip to Content
0

SAP HANA XSA WebIDE 2.0 SP 1: Monitor - Admin Tool - Set Memory (Scale) for the web and js app.

Jun 08, 2017 at 05:04 PM

173

avatar image

Hi,

if we set the memory for our js and web modul in the xs advanced administration tool, than we loose the new set memory values sometimes (not sure when this happens... maybe after cloning again).

To get sure that the memory doesn't change, I would like to set the memory within the mta file.

But I don't know if this is possible and how do I have to do it?

Any advice would be great!

Thanks a lot!

memory.png (20.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Thomas Jung
Jun 08, 2017 at 08:34 PM
0

Never change the mta file itself. Instead use an mtaext file during deployment to override or enhance settings from the original mta. A great example of this is the SAP Web IDE for SAP HANA. It requires an mtaext to perform the installation and a sample mtaext is packaged with it and available for download from the Service Marketplace.

Share
10 |10000 characters needed characters left characters exceeded
Dirk Raschke Jun 12, 2017 at 10:27 AM
0

Could somebody tell me, if we would change the default parameters for di-core and webide (by mtaext as TJ mentioned), that it will also work for our projects.

For instance, If we would set the webide from 512 M to 2048 M, does it would also include the js and web projects. We realized in the past, we had to set the memory much more higher, otherwise the modules are crashing while we we starting them. (unfortunately without any hint in the log)

Show 8 Share
10 |10000 characters needed characters left characters exceeded

Tried to change the memory via mtaext file, but it doesn't work for us. Nothing has changed.

For instance:

  - name: webide
    parameters:
      port: 53075
      host: webide
      memory: 2048M<br>

Is there a way to change the default-memory by CLI?

Tried to change it with command:

>xs set-env webide MEMORY_LIMIT 2048

But this also doesn't work, get this error:

T:\xsa>xs set-env webide MEMORY_LIMIT 2048 Setting env variable "MEMORY_LIMIT" to "2048" for app "webide"... FAILED: Environment variable 'MEMORY_LIMIT' is reserved for internal usage. Could not update environment for app "webide"

Any help would be great!

0

What do you mean also work for your projects? You mean what you build/run from the Web IDE? The MTAEXT of the Web IDE isn't going to impact the memory parameters on the applications which you build.

0

"You mean what you build/run from the Web IDE?" --> Yes

"The MTAEXT of the Web IDE isn't going to impact the memory parameters on the applications which you build."--> Ok, if not. Is there another way to set the default? We recognized that we do have a much more better performance (and starting the js and web model do not crash each time) while we were setting the memory higher.

Problem is, that the memory parameters we were setting by monitor disappear after short time.

0

I checked further the docu...

https://help.sap.com/viewer/6b94445c94ae495c83a19646e7c3fd56/2.0.01/en-US/c6cf259769bd4e00bfd722f6a44220b5.html

I would think it should also work with the admin tool, but it doesn't work for long time. But again, if does someone knows another way, please let me know.

0

If you want the settings to impact the applications you are building, you should change the parameters in the mta.yaml of the new applications.

0

Was trying it, but couldn't find any working solution and nothing within the documentation. If you do have one sample, it would be great. Than I would give it a try, too.

I got furthermore this working solution. Maybe someone needs it.

xs scale app-name-js -m 2048M

But the problem is still there, after starting the js modul the new value disappears and the old value is again "512MB"

.

0

You use the same parameters section and syntax that you would in the mtaext. The mtaext just gets merged into the mta.yaml at deploy time so their are essentially the same thing. Here is an example of a module that uses the parameters section, although I'm not setting the memory settings:

  - name: openSAP-ex-web
    type: html5
    path: web
    provides:
      - name: web
        properties:
          ui-url: '${default-url}'
    parameters:
      host: openSAP-web
      register-service-url: true
      service-name: openSAP-web
      service-url: '${default-url}'
1

Thomas, thanks a lot.

This is what I was looking for! Included it for js and web modul and it seems to work. Tried it more often to restart the app and the memory hasn't disappeared. Hopefully it stays that way...

- name: web
  type: html5
  path: web
  parameters:
    memory: 2048M
0