Skip to Content
0
Jun 08, 2017 at 02:22 PM

Why Web IDE Multi-Cloud Version doesn' t have SAPUI5 build plugin?

196 Views Last edit May 27, 2020 at 06:15 PM 2 rev

Dear SAP,

Recently you released new Web IDE version:

https://help.sap.com/viewer/825270ffffe74d9f988a0f0066ad59f0/CF/en-US

which is supposed to be new version of existing product.

Meanwhile I noticed at least one reason preventing us from using it.

In the classic web IDE we have this plugin:chrome-2017-06-08-16-12-38.png

which provide us the following settings:chrome-2017-06-08-16-14-13.png

Why it's very important for us:

  • It creates component-preload.js file which significantly reduces the number of requests and improves the performance
  • it deploys not webapp but the content of webapp

The last point becomes very critical as redeployment of a new app changes paths to existing files on ABAP server which leads to broken links (for example target mapping for tiles after deployment from new Web IDE should containg /webapp suffix while now it's not needed.

However in new IDE I see also some plugins:

chrome-2017-06-08-16-19-50.png

Among them I see grunt plugin which probably let us execute own grunt tasks before deploying.

Can you provide any workaround to solve the component-preload.js and /webapp promems in new Web IDE?

Thanks!

Petr