Skip to Content
avatar image
Former Member

J2EE Engine config is working on my system, but it's not working on other

Hi !!

I need a help regarding J2EE Engine. I have created an application in Webdynpro, but J2EE is showing N/A status. <b>Now the problem is I have configured the j2EE engine using steps windows --> preferences --> SAP J2EE Engine --> Message server Host: gsapepdev ; Message server Port: 3602. This particular configuration is working on my system but it's not working for my Colleague.</b> Can anyone suggest me the solution and reason why its happening. Is different system require different J2EE Engine settings ???

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 02, 2007 at 05:42 AM

    Hi Gianluca

    Thanks for your kind help.

    I tried out your solution as following.

    <b>1]</b> <b>Proxy server</b>

    I configured the proxy server successfully.

    <b>2]</b> <b>J2EE Engine</b>

    I have checked the J2EE Engine domain, which is same as mine.(As on mine

    system the J2EE Engine is working properly).

    <b>3]</b> <b>JDI --> Development Configuration Pool --> As we have Firewall installed i can't ping server.</b>

    Can there be any problem due to Firewall ??

    Please healp me.

    Thanks and regards

    Abhijeet

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Abhijeet,

      yes the problem is due to the firewall. You must add a rule that refers to your J2EE server.

      Add the IP of your J2EE Engine into the firewall rules to allow comunication with it.

      don't forget to award points...thank you.

      Best regards,

      Gianluca Barile

  • avatar image
    Former Member
    Mar 31, 2007 at 11:41 AM

    Abhijeet,

    go unser <b>Windows</b> -> <b>Preferences</b>:

    under <b>Workbech </b>-> <b>Proxy Settings</b>, check if you have set any proxy;

    under <b>SAP Enterprise Portal</b>, add as default your server with full qualified name (<protocol>://<server name & domain>, <web appl server port>);

    under the <b>J2EE Engine</b> menu, check the domain of your host (also please check if you and your collegues are in the same domain);

    under <b>JDI</b> -> <b>Development Configuration Pool</b>, set your server's URL and try the ping;

    If your server host is in certain domain,you can simply adding the corresponding record to the file <b>%WINDIR"/system32/drivers/etc/hosts</b> on the IDE hosts, so that the remote host short name is known to the local host.

    PS: Award points for good answers.

    Best regads,

    Gianluca Barile

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 02, 2007 at 08:09 AM

    Hi Abhijeet,

    On your friend's machine add the IP / Host address of the machine <b>gsapepdev</b> in the HOSTS file.

    This file can be found under Start -> Run -> enter Drivers -> in the ETC folder access the hosts file.

    Open it using Notepad and enter the entry for the server as:

    <IP address>[tab]<Machine name>

    Save it after entering a new line at the end...

    Hope it helps.

    Regards,

    Alka

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Alka,

      I already marked this solution to Abhijeet in my first post,

      and doesn't solve the issue.

      Regards,

      Gianluca Barile

  • avatar image
    Former Member
    Apr 02, 2007 at 09:25 AM

    Hi Gianluca

    Thanks for your solution.... This time you hit the bull's eye.

    I got my error it was due to Firewall. My system was not identifying the system through it's name. Finally i provided the rules to Firewall / server communication. I am also using IP address of EP server.

    Thanks

    and regards

    Abhijeet

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 02, 2007 at 09:29 AM

    Hi Alka

    Thanks for your solution.

    Now i tried the steps provide by you and Gianluca again and found the entry.

    Thanks and here are your points

    Regards

    Abhijeet

    Add comment
    10|10000 characters needed characters exceeded