Skip to Content
0

IoT Service doesn't start

Jun 08, 2017 at 09:01 AM

161

avatar image
Former Member

Hello

I am testing the IoT Service of HCP (trial account) since 1 month.

The app works fine, the device send data every minute. I got lot of data.

Yesterday the app is stopped. I tried to start it from cockpit but it take long time then I get failed.

I took a look on log file and I got:

transaction rolled back by an internal error: exception 1000002: Allocation failed

Can you please explain this ? and what should I do to handle this allocation error.

I tried also to see data with HANA Studio but I couldn't access data and I get error when I try to add the cloud system.

Please find attached the log file.

PS: I am working with HANA Trial.

Best regards

Houssem

cockpit.png (56.5 kB)
hanastudio.png (41.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Anton Levin
Jun 09, 2017 at 01:37 PM
0

Hello Houssem, shared HANA system should be up and running again. May I please ask you to re-start IoT MMS and shortly confirm that it works on your side? Thanks, Anton

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Anton,

It works. Thanks. Is this problem affect only the HANA Shared system ? Our client would like to migrate to HANA but after this error, he would like first to know more about this problem.

0

It was a temporary unavailability of the shared HANA instance on a Trial landscape.

1
Frank Schuler
Jun 08, 2017 at 10:08 AM
-1

Hello Houssem,

Can you please check that your iotmms service is in fact running.

Best regards

Frank


iotmms.png (79.9 kB)
Show 5 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hallo Frank

Thanks for your reply,

That is my problem, the app wouldn't run

iot.png (11.0 kB)
0
Former Member

Hello Houssem,

Could you please check the defaultTraces? What are the exact errors inside?

This morning I have experienced the issue with the starting iotmms because database connection was not set. I did not have Data Source Binding setup.

Hence, I have created a new HANA DB MDC instance and added new data source binding for iotmms.

https://help.hana.ondemand.com/iot/frameset.htm?da35019231f04cdda975c530baafbb0d.html

Regards

Kate

0
Former Member

Hi Kate

Thanks for your reply.

Actually I got too much error in log file most of them are :

2017 06 07 17:08:00#+00#ERROR#com.sap.iotservices.mms.config.ConfigurationDbManager##anonymous#localhost-startStop-1#na#p1942584482trial#iotmms#web##Failed to check if the configuration table exists in the data base.com.sap.db.jdbc.exceptions.jdbc40.SQLTransactionRollbackException: [129]: transaction rolled back by an internal error: exception 1000002: Allocation failed 

I think the problem is related to database and I tried to get data with HANA Studio but I get error too.

The data source binding is ok, is that right ?

error-log.png (66.6 kB)
iotbinding.png (5.3 kB)
0

Hello Houssem,

the very top entry looks suspicious -> "InvalidAuthorizationSpecException". Are you using shared HANA or HANA MDC instance? In case of MDC, double check if you have entered correct DB user credentials when creating a binding (it also might happen that old MDC was stopped - it has a limited lifetime on Trial, you have acquired a new one but did not update the data source binding for iotmms).

Regards,

Anton

0
Former Member
Anton Levin

Hi Anton,

This is very strange because It worked since one month without any problem.

I am using HANA shared.

regards

Houssem

0
Anton Levin
Jun 08, 2017 at 04:57 PM
0

Hello Houssem, I have sent you a direct message asking for your account ID, so that we could check in more details what went wrong. Regards, Anton

Show 1 Share
10 |10000 characters needed characters left characters exceeded

An internal ticket is there. I will let you know once that shared HANA DB instance is reachable again. Sorry for the inconvinience, Anton

0