Skip to Content
0

CMC : Scheduling Instances are Failing but Crystal output appears in File System

Jun 07, 2017 at 11:34 PM

112

avatar image

Hi All,

Please advise.

Instances are failing in CMC scheduling, but the Crystal report outputs (Excel Format) are moved to destinations as usual instead of failing.[which is shocking]

But, no email notifications are coming and Instance Status is Failed.

Destination is File System. It is running fine from past 150 days. all of a sudden got this issue.

FYI - Around 25 Recurrences run at a time.

Job Server : Adaptive Job Server [ restarted the server but no use]

(Error : Object failed to run due to an error while processing on the Job Server)

Thanks

karthik

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Dell Stinnett-Christy Jun 08, 2017 at 03:47 PM
0

You'll probably need to look at the logs for the Job Server Child processes to see what the full error is. If you have a cluster with multiple job servers, you'll need to look at the failure info for the report to determine which server's logs to look at.

It sounds like the report is running correctly, but there's an error when the SMTP part for the notification occurs. I would also try testing to see if a schedule to an email destination will run successfully.

Assuming that you're using Exchange for your email server, have there been any security changes for it recently? I've seen situations where Exchange has to have a rule set up to specifically allow SMTP requests from the BusinessObjects servers in order to successfully send emails.

-Dell

Show 5 Share
10 |10000 characters needed characters left characters exceeded

Hi Dell,

Thanks for your Suggestion. I'm using Adaptive Job Server for to schedule my Crystal Reports. No Child processes.

No security changes have been there for the Email Server in recent times. I've been using Server default Settings for email notifications. Anyhow, it is good earlier.

Thanks,

Karthik

0

Which version of BusinessObjects are you using? If it's earlier than 4, then you'll look at the Job Server logs. If it's 4.x, the job servers automatically spawn child processes that handle the scheduling. For "classic" Crystal, the job server/job server child will handle ALL of the processing for the scheduled report. For Crystal for Enterprise and Webi, the job server/job server child passes the processing off to the appropriate Processing Server. The email notification for all of them will be handled in the job server/job server child as well.

-Dell

0

Dell,

Current Version is 4.x and Crystal Reports 2013.

Not sure how to fix this error.

Thanks

Karthik

0

Someone who has access to the server(s) where BO is running will need to get the job server child logs for you. You'll need to look at them for errors that indicate exactly what's happening. The error you're seeing in BO is very generic and doesn't give the details needed to diagnose and fix the issue.

-Dell

2

Dell,

Thank you for your time in exploring this issue.

-Karthik

0